axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Thilina Mahesh Buddhika <thilin...@gmail.com>
Subject Re: [VOTE] Apache Rampart 1.5.1 release
Date Mon, 03 Jan 2011 09:00:23 GMT
And also following modification should be applied to the bin.xml, so that it
will copy the correct OpenSAML jar to the distribution.

Index: modules/distribution/bin.xml
===================================================================
--- modules/distribution/bin.xml (revision 1054533)
+++ modules/distribution/bin.xml (working copy)
@@ -22,7 +22,7 @@
                 <include>org.apache.rampart:rampart-core:jar</include>
                 <include>org.apache.rampart:rampart-policy:jar</include>
                 <include>org.apache.rampart:rampart-trust:jar</include>
-                <include>org.opensaml:opensaml:jar</include>
+                <include>org.opensaml:opensaml1:jar</include>
                 <include>org.opensaml:xmltooling:jar</include>
                 <include>joda-time:joda-time:jar</include>
                 <include>org.slf4j:slf4j-api:jar</include>


Thanks,
Thilina
Thilina Mahesh Buddhika
http://blog.thilinamb.com


On Mon, Jan 3, 2011 at 12:38 PM, Thilina Mahesh Buddhika <
thilinamb@gmail.com> wrote:

> Hi Shankar,
>
> We can replace the OpenSAML 1.1 dependency with the following entry and
> remove the WSO2 M2 repo from the root pom.xml.
>
>         <dependency>
>             <groupId>org.opensaml</groupId>
>             <artifactId>opensaml1</artifactId>
>             <version>1.1</version>
>         </dependency>
>
> Thanks,
> Thilina
>
> Thilina Mahesh Buddhika
> http://blog.thilinamb.com
>
>
> On Thu, Dec 30, 2010 at 10:42 AM, Selvaratnam Uthaiyashankar <
> uthaiyashankar@gmail.com> wrote:
>
>> On Wed, Dec 29, 2010 at 9:37 PM, Thilina Mahesh Buddhika
>> <thilinamb@gmail.com> wrote:
>> >
>> >
>> > On Wed, Dec 29, 2010 at 12:20 PM, Ruwan Linton <ruwan.linton@gmail.com>
>> > wrote:
>> >>
>> >> Hi Andreas,
>> >> Please see my comments inline;
>> >>
>> >> On Tue, Dec 28, 2010 at 5:48 PM, Andreas Veithen
>> >> <andreas.veithen@gmail.com> wrote:
>> >>>
>> >>> There is another issue with that release caused by the change in
>> >>> r1051839, which adds http://dist.wso2.org/maven2 as a repository. The
>> >>> problem is that this repository is not properly managed.
>> >>
>> >> Well as of what you have found this statement seems to be correct, but
>> it
>> >> is a mistake that we have done, and we are managing the WSO2 m2 repo
>> >> properly.
>> >>
>> >>>
>> >>> It contains
>> >>> artifacts with the same groupId, artifactId and version as Maven
>> >>> central, but with different content. Example:
>> >>>
>> >>>
>> >>>
>> http://dist.wso2.org/maven2/org/apache/axis2/addressing/1.5/addressing-1.5.pom
>> >>>
>> >>>
>> http://repo1.maven.org/maven2/org/apache/axis2/addressing/1.5/addressing-1.5.pom
>> >>
>> >> Regarding this particular issue, if you carefully have a look, the pom
>> on
>> >> the WSO2 m2 repo points to the 1.5-wso2v4 as it's parent, and the
>> mistake
>> >> there was that the addressing version has not been updated and it is
>> >> deployed as a 1.5 version. I guess this happened because Axis2 fails to
>> >> resolve the module version with letters in the trailing part like
>> wso2v4.
>> >>
>> >>>
>> >>> This threatens the stability of the build of the Rampart project as
>> >>> well as downstream projects. We had lots of issues with the java.net
>> >>> repository, which is also not managed properly, and Axis2 now no
>> >>> longer relies on this repository. We should not make the same mistake
>> >>> again.
>> >>
>> >> I am not quite sure why the WSO2 m2 repo is being added to rampart as I
>> do
>> >> not see any specific WSO2 dependency being added to rampart.
>> >
>> > Sorry for being late to reply. We had to add this repository in order to
>> get
>> > opensaml-1.1.406 artifacts which contains a bug fix which is required
>> for
>> > certain WS-Trust related scenarios to work out of the box.
>> >
>> > Rampart 1.5 [1] was also released with having WSO2 M2 repo listed as a
>> > repository due to some issues we had (I can't recall the exact reason).
>> So
>> > we added WSO2 M2 repo, which contains this patched version of OpenSAML
>> 1.1
>> > artifacts.
>>
>>
>> Thilina, AFAIK this particular version (opensaml-1.1.40) is needed
>> only for some features demonstrated in sample 5 right? How about if we
>> ask users to download this version of opensaml as part of sample
>> configuration procedure? I can see that the instructions are  already
>> available in [1].  In that case, can we remove the repo and have the
>> dependency to opensaml 1.1, which is available in [2]?
>>
>> Regards,
>> Shankar
>>
>> [1]
>> https://svn.apache.org/repos/asf/axis/axis2/java/rampart/trunk/modules/rampart-samples/policy/sample05/README.txt
>> [2] http://repo2.maven.org/maven2/org/opensaml/opensaml/
>>
>> >
>> > If we can push these OpenSAML-1.1.406 related artifacts into an Apache
>> repo,
>> > this we can remove the newly added repository entry.
>>
>>
>>
>>
>>
>> >
>> > Thanks,
>> > Thilina
>> >
>> >
>> >>
>> >> Being said that we are managing the repository properly and we are in
>> the
>> >> process of getting Nexus or some infrastructure inplace for managing
>> the
>> >> repo decently.
>> >> Thanks,
>> >> Ruwan
>> >>
>> >>>
>> >>> Therefore my vote is -1.
>> >>>
>> >>> Andreas
>> >>>
>> >>> On Thu, Dec 23, 2010 at 05:37, Selvaratnam Uthaiyashankar
>> >>> <uthaiyashankar@gmail.com> wrote:
>> >>> > Devs,
>> >>> >
>> >>> > This is the vote for Apache Rampart 1.5.1 release.
>> >>> >
>> >>> > Please review the signed artifacts:
>> >>> >
>> >>> > http://people.apache.org/~shankar/rampart/1.5.1/dist/
>> >>> >
>> >>> > The m2 repository is available at:
>> >>> > http://people.apache.org/~shankar/rampart/1.5.1/m2_repo/
>> >>> >
>> >>> > The site is temporarily hosted at:
>> >>> > http://people.apache.org/~shankar/rampart/1.5.1/site/
>> >>> >
>> >>> > SVN Info:
>> >>> >
>> https://svn.apache.org/repos/asf/axis/axis2/java/rampart/tags/v1.5.1
>> >>> >
>> >>> > It was tested against Axis2 release candidates hosted in:
>> >>> > http://people.apache.org/~veithen/1.5.4/
>> >>> >
>> >>> > Here's my +1 (binding) to declare the above dist as Apache Rampart
>> >>> > 1.5.1
>> >>> >
>> >>> > thanks,
>> >>> > Shankar
>> >>> >
>> >>> >
>> ---------------------------------------------------------------------
>> >>> > To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
>> >>> > For additional commands, e-mail: java-dev-help@axis.apache.org
>> >>> >
>> >>> >
>> >>>
>> >>> ---------------------------------------------------------------------
>> >>> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
>> >>> For additional commands, e-mail: java-dev-help@axis.apache.org
>> >>>
>> >>
>> >>
>> >>
>> >> --
>> >> Ruwan Linton
>> >> Software Architect & Product Manager
>> >> WSO2 Inc.; http://wso2.org
>> >>
>> >> Lean . Enterprise . Middleware
>> >>
>> >> phone: +1 408 754 7388 ext 51789
>> >> email: ruwan@wso2.com; cell: +94 77 341 3097
>> >> blog: http://blog.ruwan.org
>> >> linkedin: http://www.linkedin.com/in/ruwanlinton
>> >> google: http://www.google.com/profiles/ruwan.linton
>> >> tweet: http://twitter.com/ruwanlinton
>> >
>> >
>>
>>
>>
>> --
>> S.Uthaiyashankar
>> Senior Architect & Senior Manager
>> WSO2 Inc.
>> http://wso2.com/ - "lean . enterprise . middleware"
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
>> For additional commands, e-mail: java-dev-help@axis.apache.org
>>
>>
>

Mime
View raw message