axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject [General] MNG-4957 and InvalidPluginDescriptorException
Date Tue, 01 Feb 2011 07:15:53 GMT
All,

I just noticed MNG-4957 which basically says that "SNAPSHOT" will no
longer be a supported version number and that we have to use
"x.y-SNAPSHOT". Creating release branches using maven-release-plugin
is a good opportunity to implement that change because the plugin will
ask for the new trunk version anyway. However, if somebody wants to do
that at an earlier point, please feel free to do so.

I also noticed that after the recent Hudson upgrade, our builds now
appear to use Maven 3. This causes some troubles because Maven 3 no
longer supports uniqueVersion=false, which means that snapshots are
always deployed with a timestamped version number. For some reason,
this causes an InvalidPluginDescriptorException when the snapshot
versions of the AAR/MAR plugins are used (see e.g. the Sandesha2
build). This may actually be related to the previous item about
SNAPSHOT versions. Therefore I will probably already change the
version number of the Axis2 trunk to 1.6-SNAPSHOT in an attempt to
solve that issue.

Andreas

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message