axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Neil Morrison (Closed) (JIRA)" <>
Subject [jira] [Closed] (AXIS2-5192) WSDL2Java fails generation if a SimpleType with a name of "prn" is used
Date Tue, 22 Nov 2011 22:00:40 GMT


Neil Morrison closed AXIS2-5192.

    Resolution: Not A Problem

Eureka - found the problem!!!

Windows has certain filenames that can't be created, e.g. lpt, con, prn, aux, etc

So, basically the system hangs creating the file which indirectly tries to send data
to the PRN device
> WSDL2Java fails generation if a SimpleType with a name of "prn" is used
> -----------------------------------------------------------------------
>                 Key: AXIS2-5192
>                 URL:
>             Project: Axis2
>          Issue Type: Bug
>          Components: wsdl
>    Affects Versions: 1.5.1, 1.6.1
>         Environment: Windows XP SP3, Tried multiple versions of java, AXIS 1.6.1
>            Reporter: Neil Morrison
>            Priority: Minor
>              Labels: adb, adb-codegen, xml
> We have an internal identifier which is know by the name PRN (ie. PersonReferenceNumber)
> When we use an element referencing a SimpleType with the above name the WSDL2Java process
hangs for numerous minutes and then fails with the following error:
> (Location of error unknown) The device is not connected.
> The problem is case-insensitive, so PRN, prn, Prn all do the same thing.  Adding another
letter, e.g. XPrn works just fine.
> Have tried this on Axis 1.5.1 and 1.6.1 - fails on both
> Have also tried generating using other java generation options, e.g. XMLBeans, etc -
all seem to fail the same way
> Sample schema:
> <?xml version="1.0" encoding="UTF-8"?>
> <xsd:schema targetNamespace="" xmlns:eb=""
xmlns:ic="" xmlns:chg=""
> 	<xsd:element name="finaliseChargeRequest">
> 		<xsd:complexType>
> 			<xsd:sequence>
> 				<xsd:element name="header" type="xsd:string" />
> 				<xsd:element name="charge" type="xsd:string" />
> 				<xsd:element name="namePrn" type="eb:PRN" />
> 			</xsd:sequence>
> 		</xsd:complexType>
> 	</xsd:element>
> 	<xsd:element name="finaliseChargeResponse">
> 		<xsd:complexType>
> 			<xsd:sequence>
> 				<xsd:element name="header" type="xsd:string" />
> 			</xsd:sequence>
> 		</xsd:complexType>
> 	</xsd:element>
> 	<xsd:simpleType name="PRN">
> 		<xsd:restriction base="xsd:long" />
> 	</xsd:simpleType>
> </xsd:schema>
> -------------------------------------
> 23/11/2011 - Neil Morrison
> I've spent a bit more time investigating the problem and refined the problem down a little
so it has nothing to do with WSDL2Java
> I've cut the schema down to a bare minimum:
> <?xml version="1.0" encoding="UTF-8"?>
> <xsd:schema targetNamespace="" xmlns:test=""
xmlns:xsd="" elementFormDefault="qualified">
> 	<xsd:simpleType name="PRN">
> 		<xsd:restriction base="xsd:string" />
> 	</xsd:simpleType>
> 	<xsd:element name="namePrn" type="test:PRN" />
> </xsd:schema>
> And, then used the XSD2Java generator to attempt to generate it also locks up and fails
after numerous minutes
> Same solution works - change the name from PRN to something like MyPRN and all works
> Will continue looking further - if this issue needs moving to another project let me

This message is automatically generated by JIRA.
If you think it was sent incorrectly, please contact your JIRA administrators:!default.jspa
For more information on JIRA, see:


To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message