axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Fwd: Job is missing (was Re: java 5 build fails)
Date Sat, 03 Aug 2013 19:17:30 GMT
It's probably time to reopen the discussion about support for Java 1.5
in Axis2. My POV has always been that we should drop support for Java
1.5 only if there are good reasons to do so. Obviously the fact that
we no longer have a continuous integration system able to support Java
1.5 builds out of the box is a good reason. Note that it is still
possible to maintain Java 1.5 compatibility even if we build with
newer Java version (the Axiom and Axis 1.4 jobs are configured like
that), but this requires some work. Another good reason to drop
support for Java 1.5 is that it becomes increasingly difficult to keep
all dependencies compatible with Java 1.5 (e.g. there was a discussion
in the MIME4J project about that a couple of weeks ago).

Some people have pointed out that Java 1.5 is EOL for a long time now.
However, this only applies to Oracle's JRE. IBM still has a supported
WebSphere version (6.1) that runs on (IBM) Java 1.5. However, end of
support for that version is 30 September 2013, i.e. really soon. This
means that one argument in favor of keeping Java 1.5 support is about
to become irrelevant.

Andreas

---------- Forwarded message ----------
From: Olivier Lamy <olamy@apache.org>
Date: Wed, Jul 24, 2013 at 11:43 AM
Subject: Re: Job is missing (was Re: java 5 build fails)
To: "builds@apache.org" <builds@apache.org>, Andreas Lehmkühler
<andreas@lehmi.de>


doh the upgrade has changed some datas and not possible to downgrade.
So I have upgraded again.
If you really want to build 1.5 you must use a freestyle job.
The good point is I can upgrade now to a more recent version of tomcat 7.x


2013/7/24 Andreas Lehmkühler <andreas@lehmi.de>:
> Hi,
>
>> Andreas Lehmkühler <andreas@lehmi.de> hat am 24. Juli 2013 um 10:50
>> geschrieben:
>>
>>
>> Hi,
>>
>> > Olivier Lamy <olamy@apache.org> hat am 24. Juli 2013 um 10:28 geschrieben:
>> >
>> >
>> > Hi,
>> > I upgraded our jenkins instance because last versions has a lot of
>> > improvements (performance) especially for Maven jobs type.
>> > But this mean it's not possible anymore to build with 1.5 (except if
>> > you use freestyle jobs rather than maven job type or except if I can
>> > fix that :-)).
>> > So even if 1.5 is EOL for a while now..., I will revert that as it
>> > looks to be used here.
>> That would be nice, as I guess PDFBox isn't the only projects using 1.5,
>> at least for one of our builds (PDFBox 1.8.x)
>>
>> BTW: Did this update possibly broke something else? One of our jobs
>> just disappeared (again).
> Sorry, I forgot some additional information. I'm talking about the
> "PDFBox-trunk"-job. Last time it ran was yesterday. There are not logs about
> deleting it. The last log entry is about my configuration change.
>
> 2013-07-22_19-29-06     PDFBox-trunk    Changed lehmi   View as XML  (RAW)
>
> Any Ideas?
>
> BR
> Andreas Lehmkühler



--
Olivier Lamy
Ecetera: http://ecetera.com.au
http://twitter.com/olamy | http://linkedin.com/in/olamy

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message