axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "serenne (JIRA)" <j...@apache.org>
Subject [jira] [Created] (AXIS2-5695) AXIS2 not working if webappWar not exploed
Date Wed, 15 Apr 2015 14:59:58 GMT
serenne created AXIS2-5695:
------------------------------

             Summary: AXIS2 not working if webappWar not exploed
                 Key: AXIS2-5695
                 URL: https://issues.apache.org/jira/browse/AXIS2-5695
             Project: Axis2
          Issue Type: Bug
          Components: deployment
    Affects Versions: 1.6.2
         Environment: Tomact 7 Websphere 6 using webd services inside the webapp war
            Reporter: serenne


When the war is not exploded by the jee webserver (so ran as war unpacked) I get an error
at deployment time and no WebServices get deployed.

I fixed that in org.apache.axis2.deployment.DeploymentEngine.java adding

axisConfig.setRepository(repoURL); // PHS patch 
after line 337 so resulting code looks like :

org.apache.axis2.util.Utils.                  calculateDefaultModuleVersion(axisConfig.getModules(),
axisConfig);
axisConfig.setRepository(repoURL); // PHS patch
axisConfig.validateSystemPredefinedPhases();

This works fine for us, and we live now using this patched version.

But if this could be introduced in the official version, could allow us to avoid patching
at each revision.

regards






--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message