axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (AXIS2-5573) web service calls with empty namespace elements fail in 1.6.2
Date Sat, 04 Jul 2015 19:11:04 GMT

     [ https://issues.apache.org/jira/browse/AXIS2-5573?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Andreas Veithen resolved AXIS2-5573.
------------------------------------
       Resolution: Fixed
    Fix Version/s: 1.6.3

> web service calls with empty namespace elements fail in 1.6.2
> -------------------------------------------------------------
>
>                 Key: AXIS2-5573
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5573
>             Project: Axis2
>          Issue Type: Bug
>          Components: om
>    Affects Versions: 1.6.2
>         Environment: any
>            Reporter: Keith Roberts
>             Fix For: 1.6.3
>
>
> Axiom 1.2.13 introduced a bug where elements like this <element xmlns=""> return
null for the namespace and fail
> https://issues.apache.org/jira/browse/AXIOM-441
> This is fixed in Axiom 1.2.14, but this broke any service call to Axis2 1.6.2 that calls
with elements like that.
> I dropped in the Axis2-axiom jars (1.2.12) from 1.6.1, and the calls started working.
> This occurred when using .net wsdl.exe to make calls to a service where the schema states
elementFormDefault="unqualified"



--
This message was sent by Atlassian JIRA
(v6.3.4#6332)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message