axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Veithen <andreas.veit...@gmail.com>
Subject Re: Runtime error 'undeclared namespace "t"'
Date Fri, 23 Jun 2017 19:32:35 GMT
Total nonsense. XML allows both single and double quotes.

Andreas

On Fri, Jun 23, 2017 at 8:03 PM, Martin Gainty <mgainty@hotmail.com> wrote:
> tick marks are a part of CDATA and not a URL delimiter which are you
> attempting to declare example:
>
>
> 2.1.7.5 enterprise.wsdl
>
>
> <definitions targetNamespace="urn:enterprise.soap.sforce.com"
>              xmlns="http://schemas.xmlsoap.org/wsdl/"
>              xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
>              xmlns:xsd="http://www.w3.org/2001/XMLSchema"
>              xmlns:tns="urn:enterprise.soap.sforce.com"
>              xmlns:fns="urn:fault.enterprise.soap.sforce.com"
>              xmlns:ens="urn:sobject.enterprise.soap.sforce.com">
>
> note there are no tick marks in this wsdl nor in any other wsdl namespace
> declarations in 2.1.7.5 distro
>
> How did you get tick mark to work as namespace URL delimiter?
>
> Martin
>
>
>
> ________________________________
> From: Robert Seletsky <rseletsk@unm.edu>
> Sent: Friday, June 23, 2017 11:27 AM
> To: java-dev@axis.apache.org
> Subject: Re: Runtime error 'undeclared namespace "t"'
>
>
> Hello Martin,
>
>   I can not read your reply, but resolved this issue by rebuilding WSDL
> with:
>
> <artifactId>axis2-wsdl2code-maven-plugin</artifactId>
>     <version>1.7.5</version>
>
> since using axis2 1.7.5
>
>
>
> ________________________________
> From: Martin Gainty <mgainty@hotmail.com>
> Sent: Friday, June 23, 2017 7:00:11 AM
> To: java-dev@axis.apache.org
> Subject: Re: Runtime error 'undeclared namespace "t"'
>
>
>
>
>
> ________________________________
> From: Robert Seletsky <rseletsk@unm.edu>
> Sent: Thursday, June 22, 2017 2:38 PM
> To: java-dev@axis.apache.org
> Subject: Runtime error 'undeclared namespace "t"'
>
>
> Getting runtime error 'undeclared namespace "t"' since ServiceStub.java
> (generated from WSDL via wsdlcode)  is missing
>
> xmlns:t='http://docs.oasis-open.org/ws-sx/ws-trust/200512'
>
>
> MG>any reason you are using single-tick ' instead of quote
>
> xmlns:t="http://docs.oasis-open.org/ws-sx/ws-trust/20051"
>
> which is in the WSDL file.
>
>
> Please advise.
>
>
> Robert
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message