axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bruno Ramos (JIRA)" <j...@apache.org>
Subject [jira] [Commented] (AXIS2-5903) WSDL2Java bug when same named element under different name space
Date Fri, 15 Dec 2017 16:21:00 GMT

    [ https://issues.apache.org/jira/browse/AXIS2-5903?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16292746#comment-16292746
] 

Bruno Ramos commented on AXIS2-5903:
------------------------------------

Thank you Robert, for answering. 

I did not get any "No schemaLocation" errors. The only error I get is the one I said, and
no matter the axis version. I just attached the error from 1.7.7. You can see it is pretty
much the same error I attached before.

But, after you said you get different errors on your machine, I tried in another computer,
a Macbook. I used the same 1.7.7 and now it worked! And I got the "No schemaLocation" errors
like you said, but it worked anyway.

Well, the problem was NOT fixed. But as long as I use the Mac I don't need it to be fixed
anymore. Maybe it is something that only happens on Windows 7.

> WSDL2Java bug when same named element under different name space
> ----------------------------------------------------------------
>
>                 Key: AXIS2-5903
>                 URL: https://issues.apache.org/jira/browse/AXIS2-5903
>             Project: Axis2
>          Issue Type: Bug
>          Components: wsdl
>    Affects Versions: 1.7.7
>         Environment: Windows 7 64-bits.
>            Reporter: Bruno Ramos
>         Attachments: PefService.wsdl, error.txt, error1.7.7.txt
>
>
> Hi, 
> I am using WSDL2Java to generate my java classes but I am having a problem with a WSDL
that contains the same named element under different namespaces. When I try I get the error
"The referenced element ... was not found".
> I use wsdt2java as: wsdt2java.bat -o c:/teste -uri c:/teste/PefService.wsdl -suppress-prefixes
> The same error appears in the 3 versions I try: 1.5.2, 1.6.2 and 1.7.7.
> The exactly error I get from this wsdl is: "The referenced element '{http://schemas.ipc.adm.br/efrete/pef/AdicionarViagem}Viagens'
was not found!". The complete error is attached.
> The WSDL to replicate the error is attached, and also can be obtained here: https://dev.efrete.com/Services/PefService.asmx?wsdl
> Any help is appreciated. 



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

---------------------------------------------------------------------
To unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org
For additional commands, e-mail: java-dev-help@axis.apache.org


Mime
View raw message