axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robertlazarski <robertlazar...@gmail.com>
Subject Re: [Axis2] Secure Cookie not returned to WebServer
Date Tue, 13 Nov 2018 14:43:46 GMT
On Tue, Nov 13, 2018 at 4:47 AM R. Lapsien <rlapsien@klv.de> wrote:

> Secure Cookie not returned to WebServer
>
>
> I'm accessing a WebService on an BEA Server from a Java client using AXIS2
> 1.7.8
>
> As can be seen in the SSL trace AXIS2 is not returning the secure cookie
> (named '_WL_AUTHCOOKIE_JSESSIONID') to the server. Therefore the second
> request to the server is answered with 401 – Unauthorized. Another cookie
> ('JSESSIONID') is returned properly.
>
> There is no problem when communicating via http / without SSL. The secure
> cookie is only send when using SSL (see:
> https://docs.oracle.com/cd/E13222_01/wls/docs103/security/thin_client.html#wp1039551
> )
>
> This problem first occured under AXIS2 1.6.3. At that time the actual
> version was 1.7.0 and 1.7.0 did fix this issue. Now with version 1.7.8 the
> problem is back. I think the problem could be connected to AXIS2-5608.
>
> Will there be a fix?
>
> Or do I miss something neccessary to return all cookies (configuration, …)?
>
> Or is there a way to do the handling of this cookie from client code?
>
>
> --
> Best regards
> Reinhard Lapsien
>
>
> --------------------------------------------------------------------- To
> unsubscribe, e-mail: java-dev-unsubscribe@axis.apache.org For additional
> commands, e-mail: java-dev-help@axis.apache.org


Axis2 works fine for me over HTTPS, the only thing to be aware IIRC is you
need this setup like so in your axis2.xml ... the following config will
allow both HTTP and HTTPS. If this doesn't work for you, I suggest you put
axis2 into debug mode and see what is the problem, I could compare with my
logs that are working fine.

    <transportReceiver name="http"
class="org.apache.axis2.transport.http.AxisServletListener">
        <parameter name="port">8080</parameter>
    </transportReceiver>

    <transportReceiver name="https"
class="org.apache.axis2.transport.http.AxisServletListener">
        <parameter name="port">8443</parameter>
    </transportReceiver>

Regards,
Robert

Mime
View raw message