axis-java-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andreas Veithen (JIRA)" <>
Subject [jira] [Commented] (AXIS2-5936) Soapenv namespace is not added implicitly or explicitly on Redhat
Date Fri, 07 Dec 2018 21:55:00 GMT


Andreas Veithen commented on AXIS2-5936:

The builds of Axis2 and Axiom (including their test suites) both succeed on RHEL 7.5 with
OpenJDK 1.8.0_191. If this was a general problem, I would expect this to trigger test failures.
Can you provide an executable Java program (ideally as a Maven project) that reproduces the

> Soapenv namespace is not added implicitly or explicitly on Redhat
> -----------------------------------------------------------------
>                 Key: AXIS2-5936
>                 URL:
>             Project: Axis2
>          Issue Type: Bug
>          Components: adb
>    Affects Versions: 1.6.4, 1.7.8
>            Reporter: Muhammad Hamid
>            Priority: Major
> Tested with Linux  (Red Hat Enterprise Linux Server release 5.11 (Tikanga) and 7.5
(Maipo)), namespace for soapenv is not being added, tried to add it implicitly, doesn't work.
> The only workaround I was able to do to fix this is to use SOAP 11 envelope, and add
it's namespace, so seems like this error is specific to SOAP 12.
> Java version in Linux: jdk1.8.0_92
> Java version in Windows: jdk1.8.0.161
> p.s in windows everything works fine, I don't have to specify envelope's version, or
namespace URI.
> another p.s: this issue had been there since version 1.6.2, and I believe it's OS specific,
should try it on newer redhat OS.
> Update: I've tried it with Redhat 7.5 Maipo, same issue

This message was sent by Atlassian JIRA

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message