beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (BEAM-1949) Rename DoFn.Context#sideOutput to #output
Date Mon, 01 May 2017 23:17:04 GMT


ASF GitHub Bot commented on BEAM-1949:

GitHub user robertwb opened a pull request:

    [BEAM-1949 Rename OutputValue to TaggedOutput.

    Be sure to do all of the following to help us incorporate your contribution
    quickly and easily:
     - [ ] Make sure the PR title is formatted like:
       `[BEAM-<Jira issue #>] Description of pull request`
     - [ ] Make sure tests pass via `mvn clean verify`. (Even better, enable
           Travis-CI on your fork and ensure the whole test matrix passes).
     - [ ] Replace `<Jira issue #>` in the title with the actual Jira issue
           number, if there is one.
     - [ ] If this contribution is large, please file an Apache
           [Individual Contributor License Agreement](

You can merge this pull request into a Git repository by running:

    $ git pull tagged-outputs

Alternatively you can review and apply these changes as the patch at:

To close this pull request, make a commit to your master/trunk branch
with (at least) the following in the commit message:

    This closes #2810
commit e17421a5f3c850f34a1074eba376f28ce69442e2
Author: Robert Bradshaw <>
Date:   2017-05-01T23:15:32Z

    Rename OutputValue to TaggedOutput.


> Rename DoFn.Context#sideOutput to #output
> -----------------------------------------
>                 Key: BEAM-1949
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-java-core
>            Reporter: Thomas Groh
>            Assignee: Thomas Groh
>             Fix For: First stable release
> Having two methods, both named output, one which takes the "main output type" and one
that takes a tag to specify the type more clearly communicates the actual behavior - sideOutput
isn't a "special" way to output, it's the same as output(T), just to a specified PCollection.
This will help pipeline authors understand the actual behavior of outputting to a tag, and
detangle it from "sideInput", which is a special way to receive input. Giving them the same
name means that it's not even strange to call output and provide the main output type, which
is what we want - it's a more specific way to output, but does not have different restrictions
or capabilities.
> This is also a pretty small change within the SDK - it touches about 20 files, and the
changes are pretty automatic.

This message was sent by Atlassian JIRA

View raw message