beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <>
Subject [jira] [Commented] (BEAM-1949) Rename DoFn.Context#sideOutput to #output
Date Tue, 02 May 2017 00:47:04 GMT


ASF GitHub Bot commented on BEAM-1949:

Github user asfgit closed the pull request at:

> Rename DoFn.Context#sideOutput to #output
> -----------------------------------------
>                 Key: BEAM-1949
>                 URL:
>             Project: Beam
>          Issue Type: Improvement
>          Components: sdk-java-core
>            Reporter: Thomas Groh
>            Assignee: Thomas Groh
>             Fix For: First stable release
> Having two methods, both named output, one which takes the "main output type" and one
that takes a tag to specify the type more clearly communicates the actual behavior - sideOutput
isn't a "special" way to output, it's the same as output(T), just to a specified PCollection.
This will help pipeline authors understand the actual behavior of outputting to a tag, and
detangle it from "sideInput", which is a special way to receive input. Giving them the same
name means that it's not even strange to call output and provide the main output type, which
is what we want - it's a more specific way to output, but does not have different restrictions
or capabilities.
> This is also a pretty small change within the SDK - it touches about 20 files, and the
changes are pretty automatic.

This message was sent by Atlassian JIRA

View raw message