beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Liu (JIRA)" <>
Subject [jira] [Created] (BEAM-2495) Python IT test fails if six<1.9
Date Wed, 21 Jun 2017 21:13:00 GMT
Mark Liu created BEAM-2495:

             Summary: Python IT test fails if six<1.9
                 Key: BEAM-2495
             Project: Beam
          Issue Type: Bug
          Components: sdk-py, testing
            Reporter: Mark Liu
            Assignee: Mark Liu

Python uses nose.plugins.0.10 to manage customized commandline argument: --test-pipeline-options
to build test pipeline options and run integration test. nose.plugins.0.10 is required six>=1.9,
otherwise, following error will occur:
RuntimeWarning: Unable to load plugin beam_test_plugin = test_config:BeamTestPlugin: (six
1.5.2 (/usr/lib/python2.7/dist-packages), Requirement.parse('six>=1.9'))
usage: [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: --help [cmd1 cmd2 ...]
   or: --help-commands
   or: cmd --help

error: option --test-pipeline-options not recognized

I think we should add this dependency to REQUIRED_TEST_PACKAGES in

This message was sent by Atlassian JIRA

View raw message