beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Liu (JIRA)" <j...@apache.org>
Subject [jira] [Created] (BEAM-2495) Python IT test fails if six<1.9
Date Wed, 21 Jun 2017 21:13:00 GMT
Mark Liu created BEAM-2495:
------------------------------

             Summary: Python IT test fails if six<1.9
                 Key: BEAM-2495
                 URL: https://issues.apache.org/jira/browse/BEAM-2495
             Project: Beam
          Issue Type: Bug
          Components: sdk-py, testing
            Reporter: Mark Liu
            Assignee: Mark Liu


Python uses nose.plugins.0.10 to manage customized commandline argument: --test-pipeline-options
to build test pipeline options and run integration test. nose.plugins.0.10 is required six>=1.9,
otherwise, following error will occur:
{code}
/tmp/perfkitbenchmarker/runs/985bc121/beam/sdks/python/nose-1.3.7-py2.7.egg/nose/plugins/manager.py:395:
RuntimeWarning: Unable to load plugin beam_test_plugin = test_config:BeamTestPlugin: (six
1.5.2 (/usr/lib/python2.7/dist-packages), Requirement.parse('six>=1.9'))
  RuntimeWarning)
usage: setup.py [global_opts] cmd1 [cmd1_opts] [cmd2 [cmd2_opts] ...]
   or: setup.py --help [cmd1 cmd2 ...]
   or: setup.py --help-commands
   or: setup.py cmd --help

error: option --test-pipeline-options not recognized
{code}

I think we should add this dependency to REQUIRED_TEST_PACKAGES in setup.py



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message