beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Al Yaros (JIRA)" <>
Subject [jira] [Commented] (BEAM-2837) Writing To Spanner From Google Cloud DataFlow - Failure
Date Wed, 06 Sep 2017 13:20:00 GMT


Al Yaros commented on BEAM-2837:

I didn't saw anything else in the error.
I also think that the reason is dependencies issue but I have tried all kind of combination
of versions (Include other and Exclude others) but still it refused to work.
You can look on the GitHub code (Link added) that this is very simple pipeline that even if
the pom only includes:


It doesn't work.

I verified that the Project\Instance\DB\Table\Columns all exists in Spanner.
I'm running it after I ran "gcloud auth application-default login" from the Cloud SDK Console
so It's not a manner of Authentication. (It starts the pipeline in DataFlow)
I have tried to Exclude Spanner from the "beam-runners-google-cloud-dataflow-java" and include
the official spanner Java driver (in different versions) and still it didn't worked.
Anyway, I'll be happy if you can share an example (Simple Code, Pom Etc..) or Versions I should
use to be able to write to Spanner from GCP DataFlow.

> Writing To Spanner From Google Cloud DataFlow - Failure
> -------------------------------------------------------
>                 Key: BEAM-2837
>                 URL:
>             Project: Beam
>          Issue Type: Bug
>          Components: runner-dataflow
>    Affects Versions: 2.1.0
>         Environment: Google Cloud DataFlow
>            Reporter: Al Yaros
>            Assignee: Mairbek Khadikov
> Simple Java Program That reads from Pub\Sub and Writes to Spanner Fails with cryptic
error message.
> Simple Program to Demonstrate the Error:
> []
> {code:java}
> *Caused by: org.apache.beam.sdk.util.UserCodeException: java.lang.NoClassDefFoundError:
Could not initialize class
>         org.apache.beam.sdk.util.UserCodeException.wrap(
> gcp.spanner.SpannerWriteGroupFn$DoFnInvoker.invokeSetup(Unknown Source)
>         java.util.concurrent.ThreadPoolExecutor.runWorker(
>         java.util.concurrent.ThreadPoolExecutor$
> {code}

This message was sent by Atlassian JIRA

View raw message