beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Henning Rohde (JIRA)" <j...@apache.org>
Subject [jira] [Resolved] (BEAM-3121) Dockerized jekyll server fails
Date Wed, 01 Nov 2017 20:08:01 GMT

     [ https://issues.apache.org/jira/browse/BEAM-3121?page=com.atlassian.jira.plugin.system.issuetabpanels:all-tabpanel
]

Henning Rohde resolved BEAM-3121.
---------------------------------
       Resolution: Fixed
    Fix Version/s: 2.3.0

> Dockerized jekyll server fails
> ------------------------------
>
>                 Key: BEAM-3121
>                 URL: https://issues.apache.org/jira/browse/BEAM-3121
>             Project: Beam
>          Issue Type: Bug
>          Components: website
>            Reporter: Henning Rohde
>            Assignee: Henning Rohde
>            Priority: Minor
>             Fix For: 2.3.0
>
>
> The dockerized jekyll script for building the website fails with the following error:
> $ ./run_with_docker.sh server
> Unable to find image 'jekyll/jekyll:latest' locally
> latest: Pulling from jekyll/jekyll
> b56ae66c2937: Pull complete 
> 337580f4eddd: Pull complete 
> f8edd684e995: Pull complete 
> 536ad31f0662: Pull complete 
> 120aeb540421: Pull complete 
> Digest: sha256:61956fbaf76be2fc23cd4908abbe1bfce6541dcdd9d9b3658b53d80b25a363a4
> Status: Downloaded newer image for jekyll/jekyll:latest
> The following gems are missing
>  * rake (11.3.0)
>  * i18n (0.7.0)
>  * json (1.8.3)
>  * minitest (5.9.1)
>  * thread_safe (0.3.5)
>  * tzinfo (1.2.2)
>  * activesupport (4.2.7.1)
>  * addressable (2.4.0)
>  * colored (1.2)
>  * ffi (1.9.14)
>  * ethon (0.9.1)
>  * mini_portile2 (2.1.0)
>  * nokogiri (1.6.8.1)
>  * parallel (1.9.0)
>  * yell (2.0.6)
>  * html-proofer (3.3.1)
>  * sass (3.4.22)
>  * jekyll-sass-converter (1.4.0)
>  * rb-fsevent (0.9.7)
>  * rb-inotify (0.9.7)
>  * kramdown (1.12.0)
>  * liquid (3.0.6)
>  * pathutil (0.14.0)
>  * rouge (1.11.1)
>  * jekyll (3.2.0)
>  * jekyll-redirect-from (0.11.0)
>  * jekyll_github_sample (0.3.0)
> Install missing gems with `bundle install`
> Fetching gem metadata from https://rubygems.org/.........
> Fetching version metadata from https://rubygems.org/..
> Fetching dependency metadata from https://rubygems.org/.
> Fetching rake 11.3.0
> Installing rake 11.3.0
> Fetching i18n 0.7.0
> Installing i18n 0.7.0
> Fetching json 1.8.3
> Installing json 1.8.3 with native extensions
> Fetching minitest 5.9.1
> Installing minitest 5.9.1
> Fetching thread_safe 0.3.5
> Installing thread_safe 0.3.5
> Fetching addressable 2.4.0
> Installing addressable 2.4.0
> Using bundler 1.15.4
> Fetching colorator 1.1.0
> Installing colorator 1.1.0
> Fetching colored 1.2
> Installing colored 1.2
> Fetching ffi 1.9.14
> Installing ffi 1.9.14 with native extensions
> Fetching forwardable-extended 2.6.0
> Installing forwardable-extended 2.6.0
> Fetching mercenary 0.3.6
> Installing mercenary 0.3.6
> Fetching mini_portile2 2.1.0
> Installing mini_portile2 2.1.0
> Fetching parallel 1.9.0
> Installing parallel 1.9.0
> Fetching yell 2.0.6
> Installing yell 2.0.6
> Fetching sass 3.4.22
> Installing sass 3.4.22
> Fetching rb-fsevent 0.9.7
> Installing rb-fsevent 0.9.7
> Fetching kramdown 1.12.0
> Installing kramdown 1.12.0
> Fetching liquid 3.0.6
> Installing liquid 3.0.6
> Fetching rouge 1.11.1
> Installing rouge 1.11.1
> Fetching safe_yaml 1.0.4
> Installing safe_yaml 1.0.4
> Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
>     current directory: /srv/jekyll/vendor/bundle/gems/json-1.8.3/ext/json/ext/generator
> /usr/local/bin/ruby -r ./siteconf20171030-31-1kumuua.rb extconf.rb
> creating Makefile
> current directory: /srv/jekyll/vendor/bundle/gems/json-1.8.3/ext/json/ext/generator
> make "DESTDIR=" clean
> current directory: /srv/jekyll/vendor/bundle/gems/json-1.8.3/ext/json/ext/generator
> make "DESTDIR="
> compiling generator.c
> generator.c: In function 'generate_json':
> generator.c:861:25: error: 'rb_cFixnum' undeclared (first use in this function)
>      } else if (klass == rb_cFixnum) {
>                          ^~~~~~~~~~
> generator.c:861:25: note: each undeclared identifier is reported only once for each function
it appears in
> generator.c:863:25: error: 'rb_cBignum' undeclared (first use in this function)
>      } else if (klass == rb_cBignum) {
>                          ^~~~~~~~~~
> generator.c: At top level:
> cc1: warning: unrecognized command line option '-Wno-self-assign'
> cc1: warning: unrecognized command line option '-Wno-constant-logical-operand'
> cc1: warning: unrecognized command line option '-Wno-parentheses-equality'
> make: *** [Makefile:242: generator.o] Error 1
> make failed, exit code 2
> Gem files will remain installed in /srv/jekyll/vendor/bundle/gems/json-1.8.3 for inspection.
> Results logged to /srv/jekyll/vendor/bundle/extensions/x86_64-linux/2.4.0/json-1.8.3/gem_make.out
> An error occurred while installing json (1.8.3), and Bundler cannot continue.
> Make sure that `gem install json -v '1.8.3'` succeeds before bundling.
> In Gemfile:
>   html-proofer was resolved to 3.3.1, which depends on
>     activesupport was resolved to 4.2.7.1, which depends on
>       json



--
This message was sent by Atlassian JIRA
(v6.4.14#64029)

Mime
View raw message