beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PerformanceTests_AvroIOIT #87
Date Wed, 31 Jan 2018 12:00:17 GMT
See <https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/87/display/redirect>

------------------------------------------
Started by timer
[EnvInject] - Loading node environment variables.
Building remotely on beam5 (beam) in workspace <https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://github.com/apache/beam.git # timeout=10
Fetching upstream changes from https://github.com/apache/beam.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/apache/beam.git +refs/heads/*:refs/remotes/origin/*
+refs/pull/${ghprbPullId}/*:refs/remotes/origin/pr/${ghprbPullId}/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 645e1b51e1c83ec4b0b54a774d6615624f3c42ed (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 645e1b51e1c83ec4b0b54a774d6615624f3c42ed
Commit message: "Merge pull request #4448: [SQL] Refactor Variance"
 > git rev-list 645e1b51e1c83ec4b0b54a774d6615624f3c42ed # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
SPARK_LOCAL_IP=127.0.0.1

[EnvInject] - Variables injected successfully.
[beam_PerformanceTests_AvroIOIT] $ /bin/bash -xe /tmp/jenkins7162931023867759835.sh
+ rm -rf PerfKitBenchmarker
[beam_PerformanceTests_AvroIOIT] $ /bin/bash -xe /tmp/jenkins1657383290183390490.sh
+ rm -rf .env
[beam_PerformanceTests_AvroIOIT] $ /bin/bash -xe /tmp/jenkins2450729506538111997.sh
+ virtualenv .env --system-site-packages
New python executable in .env/bin/python
Installing setuptools, pip...done.
[beam_PerformanceTests_AvroIOIT] $ /bin/bash -xe /tmp/jenkins544806996812323147.sh
+ git clone https://github.com/GoogleCloudPlatform/PerfKitBenchmarker.git
Cloning into 'PerfKitBenchmarker'...
[beam_PerformanceTests_AvroIOIT] $ /bin/bash -xe /tmp/jenkins6702138934175947954.sh
+ .env/bin/pip install -r PerfKitBenchmarker/requirements.txt
Downloading/unpacking absl-py (from -r PerfKitBenchmarker/requirements.txt (line 14))
  Running setup.py (path:<https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/.env/build/absl-py/setup.py)>
egg_info for package absl-py
    
Requirement already satisfied (use --upgrade to upgrade): jinja2>=2.7 in /usr/local/lib/python2.7/dist-packages
(from -r PerfKitBenchmarker/requirements.txt (line 15))
Requirement already satisfied (use --upgrade to upgrade): setuptools in ./.env/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 16))
Downloading/unpacking colorlog[windows]==2.6.0 (from -r PerfKitBenchmarker/requirements.txt
(line 17))
  Downloading colorlog-2.6.0-py2.py3-none-any.whl
Downloading/unpacking blinker>=1.3 (from -r PerfKitBenchmarker/requirements.txt (line 18))
  Running setup.py (path:<https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/.env/build/blinker/setup.py)>
egg_info for package blinker
    
Downloading/unpacking futures>=3.0.3 (from -r PerfKitBenchmarker/requirements.txt (line
19))
  Downloading futures-3.2.0-py2-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): PyYAML==3.12 in /usr/local/lib/python2.7/dist-packages
(from -r PerfKitBenchmarker/requirements.txt (line 20))
Downloading/unpacking pint>=0.7 (from -r PerfKitBenchmarker/requirements.txt (line 21))
  Running setup.py (path:<https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/.env/build/pint/setup.py)>
egg_info for package pint
    
    no previously-included directories found matching 'docs/_build'
    no previously-included directories found matching 'docs/_themes/.git'
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
    warning: no previously-included files matching '*~' found anywhere in distribution
    warning: no previously-included files matching '.DS_Store' found anywhere in distribution
    warning: no previously-included files matching '*__pycache__*' found anywhere in distribution
    warning: no previously-included files matching '*.pyo' found anywhere in distribution
    warning: no previously-included files matching '.travis-exclude.yml' found anywhere in
distribution
Downloading/unpacking numpy (from -r PerfKitBenchmarker/requirements.txt (line 22))
  Running setup.py (path:<https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/.env/build/numpy/setup.py)>
egg_info for package numpy
    Running from numpy source directory.
    /usr/lib/python2.7/distutils/dist.py:267: UserWarning: Unknown distribution option: 'python_requires'
      warnings.warn(msg)
    
    warning: no previously-included files matching '*.pyc' found anywhere in distribution
    warning: no previously-included files matching '*.pyo' found anywhere in distribution
    warning: no previously-included files matching '*.pyd' found anywhere in distribution
    warning: no previously-included files matching '*.swp' found anywhere in distribution
    warning: no previously-included files matching '*.bak' found anywhere in distribution
    warning: no previously-included files matching '*~' found anywhere in distribution
Requirement already satisfied (use --upgrade to upgrade): functools32 in /usr/local/lib/python2.7/dist-packages
(from -r PerfKitBenchmarker/requirements.txt (line 23))
Downloading/unpacking contextlib2>=0.5.1 (from -r PerfKitBenchmarker/requirements.txt (line
24))
  Downloading contextlib2-0.5.5-py2.py3-none-any.whl
Downloading/unpacking pywinrm (from -r PerfKitBenchmarker/requirements.txt (line 25))
  Downloading pywinrm-0.3.0-py2.py3-none-any.whl
Requirement already satisfied (use --upgrade to upgrade): six in /usr/local/lib/python2.7/dist-packages
(from absl-py->-r PerfKitBenchmarker/requirements.txt (line 14))
Requirement already satisfied (use --upgrade to upgrade): colorama in /usr/lib/python2.7/dist-packages
(from colorlog[windows]==2.6.0->-r PerfKitBenchmarker/requirements.txt (line 17))
Requirement already satisfied (use --upgrade to upgrade): requests>=2.9.1 in /usr/local/lib/python2.7/dist-packages
(from pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
Downloading/unpacking requests-ntlm>=0.3.0 (from pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25))
  Downloading requests_ntlm-1.1.0-py2.py3-none-any.whl
Downloading/unpacking xmltodict (from pywinrm->-r PerfKitBenchmarker/requirements.txt (line
25))
  Downloading xmltodict-0.11.0-py2.py3-none-any.whl
Downloading/unpacking cryptography>=1.3 (from requests-ntlm>=0.3.0->pywinrm->-r
PerfKitBenchmarker/requirements.txt (line 25))
  Running setup.py (path:<https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/.env/build/cryptography/setup.py)>
egg_info for package cryptography
    error in cryptography setup command: Invalid environment marker: python_version < '3'
    Complete output from command python setup.py egg_info:
    error in cryptography setup command: Invalid environment marker: python_version < '3'

----------------------------------------
Cleaning up...
Command python setup.py egg_info failed with error code 1 in <https://builds.apache.org/job/beam_PerformanceTests_AvroIOIT/ws/.env/build/cryptography>
Storing debug log for failure in /home/jenkins/.pip/pip.log
Build step 'Execute shell' marked build as failure

Mime
View raw message