beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PerformanceTests_Spark #1535
Date Sun, 01 Apr 2018 00:01:28 GMT
See <https://builds.apache.org/job/beam_PerformanceTests_Spark/1535/display/redirect>

------------------------------------------
Started by timer
[EnvInject] - Loading node environment variables.
Building remotely on beam2 (beam) in workspace <https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://github.com/apache/beam.git # timeout=10
Fetching upstream changes from https://github.com/apache/beam.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/apache/beam.git +refs/heads/*:refs/remotes/origin/*
+refs/pull/${ghprbPullId}/*:refs/remotes/origin/pr/${ghprbPullId}/*
 > git rev-parse origin/master^{commit} # timeout=10
Checking out Revision 60327674fd738221030bcba0427c5a626c967648 (origin/master)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 60327674fd738221030bcba0427c5a626c967648
Commit message: "Merge pull request #4950 from boyuanzz/microbenchmark"
 > git rev-list --no-walk 60327674fd738221030bcba0427c5a626c967648 # timeout=10
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
SPARK_LOCAL_IP=127.0.0.1

[EnvInject] - Variables injected successfully.
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins1199347824909352039.sh
+ rm -rf PerfKitBenchmarker
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins240704656597376238.sh
+ rm -rf .env
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins3946621967355443935.sh
+ virtualenv .env --system-site-packages
New python executable in <https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/bin/python>
Installing setuptools, pip, wheel...done.
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins1927509851280829100.sh
+ .env/bin/pip install --upgrade setuptools pip
Requirement already up-to-date: setuptools in ./.env/lib/python2.7/site-packages (39.0.1)
Requirement already up-to-date: pip in ./.env/lib/python2.7/site-packages (10.0.0b1)
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins5833098259028113536.sh
+ git clone https://github.com/GoogleCloudPlatform/PerfKitBenchmarker.git
Cloning into 'PerfKitBenchmarker'...
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins8790063463819073946.sh
+ .env/bin/pip install -r PerfKitBenchmarker/requirements.txt
Requirement already satisfied: absl-py in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 14)) (0.1.3)
Requirement already satisfied: jinja2>=2.7 in /usr/local/lib/python2.7/dist-packages (from
-r PerfKitBenchmarker/requirements.txt (line 15)) (2.8)
Requirement already satisfied: setuptools in ./.env/lib/python2.7/site-packages (from -r PerfKitBenchmarker/requirements.txt
(line 16)) (39.0.1)
Requirement already satisfied: colorlog[windows]==2.6.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 17)) (2.6.0)
Requirement already satisfied: blinker>=1.3 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 18)) (1.4)
Requirement already satisfied: futures>=3.0.3 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 19)) (3.1.1)
Requirement already satisfied: PyYAML==3.12 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 20)) (3.12)
Requirement already satisfied: pint>=0.7 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 21)) (0.7.2)
Collecting numpy==1.13.3 (from -r PerfKitBenchmarker/requirements.txt (line 22))
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/local/lib/python2.7/site-packages/pip/_vendor/urllib3/util/ssl_.py>:339:
SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension
to TLS is not available on this platform. This may cause the server to present an incorrect
TLS certificate, which can cause validation failures. You can upgrade to a newer version of
Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  SNIMissingWarning
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/local/lib/python2.7/site-packages/pip/_vendor/urllib3/util/ssl_.py>:137:
InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3
from configuring SSL appropriately and may cause certain SSL connections to fail. You can
upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Using cached numpy-1.13.3-cp27-cp27mu-manylinux1_x86_64.whl
Requirement already satisfied: functools32 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 23)) (3.2.3.post2)
Requirement already satisfied: contextlib2>=0.5.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 24)) (0.5.4)
Requirement already satisfied: pywinrm in /home/jenkins/.local/lib/python2.7/site-packages
(from -r PerfKitBenchmarker/requirements.txt (line 25)) (0.2.2)
Requirement already satisfied: six in /home/jenkins/.local/lib/python2.7/site-packages (from
absl-py->-r PerfKitBenchmarker/requirements.txt (line 14)) (1.10.0)
Requirement already satisfied: MarkupSafe in /usr/local/lib/python2.7/dist-packages (from
jinja2>=2.7->-r PerfKitBenchmarker/requirements.txt (line 15)) (0.23)
Requirement already satisfied: colorama; extra == "windows" in /usr/lib/python2.7/dist-packages
(from colorlog[windows]==2.6.0->-r PerfKitBenchmarker/requirements.txt (line 17)) (0.2.5)
Requirement already satisfied: xmltodict in /home/jenkins/.local/lib/python2.7/site-packages
(from pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25)) (0.11.0)
Requirement already satisfied: requests-ntlm>=0.3.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25)) (1.1.0)
Requirement already satisfied: requests>=2.9.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25)) (2.18.1)
Requirement already satisfied: ntlm-auth>=1.0.2 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt (line
25)) (1.0.6)
Requirement already satisfied: cryptography>=1.3 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt (line
25)) (2.1.2)
Requirement already satisfied: idna<2.6,>=2.5 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(2.5)
Requirement already satisfied: urllib3<1.22,>=1.21.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(1.21.1)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.9.1->pywinrm->-r PerfKitBenchmarker/requirements.txt (line 25))
(2017.4.17)
Requirement already satisfied: cffi>=1.7; platform_python_implementation != "PyPy" in /home/jenkins/.local/lib/python2.7/site-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (1.11.2)
Requirement already satisfied: enum34; python_version < "3" in /home/jenkins/.local/lib/python2.7/site-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (1.1.6)
Requirement already satisfied: asn1crypto>=0.21.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (0.23.0)
Requirement already satisfied: ipaddress; python_version < "3" in /usr/local/lib/python2.7/dist-packages
(from cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r PerfKitBenchmarker/requirements.txt
(line 25)) (1.0.19)
Requirement already satisfied: pycparser in /home/jenkins/.local/lib/python2.7/site-packages
(from cffi>=1.7; platform_python_implementation != "PyPy"->cryptography>=1.3->requests-ntlm>=0.3.0->pywinrm->-r
PerfKitBenchmarker/requirements.txt (line 25)) (2.18)
Installing collected packages: numpy
  Found existing installation: numpy 1.11.3
    Not uninstalling numpy at /home/jenkins/.local/lib/python2.7/site-packages, outside environment
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env>
    Can't uninstall 'numpy'. No files were found to uninstall.
Successfully installed numpy-1.13.3
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins6049595855311001975.sh
+ .env/bin/pip install -e 'src/sdks/python/[gcp,test]'
Obtaining file://<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/src/sdks/python>
Requirement already satisfied: avro<2.0.0,>=1.8.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (1.8.2)
Requirement already satisfied: crcmod<2.0,>=1.7 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (1.7)
Requirement already satisfied: dill==0.2.6 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.2.6)
Collecting grpcio<2,>=1.8 (from apache-beam==2.5.0.dev0)
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/local/lib/python2.7/site-packages/pip/_vendor/urllib3/util/ssl_.py>:339:
SNIMissingWarning: An HTTPS request has been made, but the SNI (Subject Name Indication) extension
to TLS is not available on this platform. This may cause the server to present an incorrect
TLS certificate, which can cause validation failures. You can upgrade to a newer version of
Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  SNIMissingWarning
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/local/lib/python2.7/site-packages/pip/_vendor/urllib3/util/ssl_.py>:137:
InsecurePlatformWarning: A true SSLContext object is not available. This prevents urllib3
from configuring SSL appropriately and may cause certain SSL connections to fail. You can
upgrade to a newer version of Python to solve this. For more information, see https://urllib3.readthedocs.io/en/latest/advanced-usage.html#ssl-warnings
  InsecurePlatformWarning
  Using cached grpcio-1.10.0-cp27-cp27mu-manylinux1_x86_64.whl
Collecting hdfs<3.0.0,>=2.1.0 (from apache-beam==2.5.0.dev0)
Requirement already satisfied: httplib2<0.10,>=0.8 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.9.2)
Requirement already satisfied: mock<3.0.0,>=1.0.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (2.0.0)
Requirement already satisfied: oauth2client<5,>=2.0.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (3.0.0)
Requirement already satisfied: protobuf<4,>=3.5.0.post1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (3.5.0.post1)
Collecting pytz>=2018.3 (from apache-beam==2.5.0.dev0)
  Using cached pytz-2018.3-py2.py3-none-any.whl
Requirement already satisfied: pyyaml<4.0.0,>=3.12 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (3.12)
Requirement already satisfied: pyvcf<0.7.0,>=0.6.8 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.6.8)
Requirement already satisfied: six<1.12,>=1.9 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (1.10.0)
Requirement already satisfied: typing<3.7.0,>=3.6.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (3.6.2)
Requirement already satisfied: futures<4.0.0,>=3.1.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (3.1.1)
Requirement already satisfied: google-apitools<=0.5.20,>=0.5.18 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.5.20)
Requirement already satisfied: proto-google-cloud-datastore-v1<=0.90.4,>=0.90.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.90.4)
Requirement already satisfied: googledatastore==7.0.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (7.0.1)
Requirement already satisfied: google-cloud-pubsub==0.26.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.26.0)
Requirement already satisfied: proto-google-cloud-pubsub-v1==0.15.4 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.15.4)
Requirement already satisfied: google-cloud-bigquery==0.25.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (0.25.0)
Collecting nose>=1.3.7 (from apache-beam==2.5.0.dev0)
  Using cached nose-1.3.7-py2-none-any.whl
Requirement already satisfied: pyhamcrest<2.0,>=1.9 in /home/jenkins/.local/lib/python2.7/site-packages
(from apache-beam==2.5.0.dev0) (1.9.0)
Requirement already satisfied: enum34>=1.0.4 in /home/jenkins/.local/lib/python2.7/site-packages
(from grpcio<2,>=1.8->apache-beam==2.5.0.dev0) (1.1.6)
Requirement already satisfied: requests>=2.7.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from hdfs<3.0.0,>=2.1.0->apache-beam==2.5.0.dev0) (2.18.1)
Requirement already satisfied: docopt in /usr/local/lib/python2.7/dist-packages (from hdfs<3.0.0,>=2.1.0->apache-beam==2.5.0.dev0)
(0.6.2)
Requirement already satisfied: funcsigs>=1; python_version < "3.3" in /home/jenkins/.local/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.5.0.dev0) (1.0.2)
Requirement already satisfied: pbr>=0.11 in /home/jenkins/.local/lib/python2.7/site-packages
(from mock<3.0.0,>=1.0.1->apache-beam==2.5.0.dev0) (3.1.0)
Requirement already satisfied: pyasn1>=0.1.7 in /home/jenkins/.local/lib/python2.7/site-packages
(from oauth2client<5,>=2.0.1->apache-beam==2.5.0.dev0) (0.2.3)
Requirement already satisfied: pyasn1-modules>=0.0.5 in /home/jenkins/.local/lib/python2.7/site-packages
(from oauth2client<5,>=2.0.1->apache-beam==2.5.0.dev0) (0.0.9)
Requirement already satisfied: rsa>=3.1.4 in /home/jenkins/.local/lib/python2.7/site-packages
(from oauth2client<5,>=2.0.1->apache-beam==2.5.0.dev0) (3.4.2)
Requirement already satisfied: setuptools in ./.env/lib/python2.7/site-packages (from protobuf<4,>=3.5.0.post1->apache-beam==2.5.0.dev0)
(39.0.1)
Requirement already satisfied: fasteners>=0.14 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-apitools<=0.5.20,>=0.5.18->apache-beam==2.5.0.dev0) (0.14.1)
Requirement already satisfied: googleapis-common-protos<2.0dev,>=1.5.2 in /home/jenkins/.local/lib/python2.7/site-packages
(from proto-google-cloud-datastore-v1<=0.90.4,>=0.90.0->apache-beam==2.5.0.dev0)
(1.5.2)
Requirement already satisfied: google-cloud-core<0.26dev,>=0.25.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0) (0.25.0)
Requirement already satisfied: gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0) (0.15.4)
Requirement already satisfied: idna<2.6,>=2.5 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.5.0.dev0) (2.5)
Requirement already satisfied: urllib3<1.22,>=1.21.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.5.0.dev0) (1.21.1)
Requirement already satisfied: chardet<3.1.0,>=3.0.2 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.5.0.dev0) (3.0.4)
Requirement already satisfied: certifi>=2017.4.17 in /home/jenkins/.local/lib/python2.7/site-packages
(from requests>=2.7.0->hdfs<3.0.0,>=2.1.0->apache-beam==2.5.0.dev0) (2017.4.17)
Requirement already satisfied: monotonic>=0.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from fasteners>=0.14->google-apitools<=0.5.20,>=0.5.18->apache-beam==2.5.0.dev0)
(1.4)
Requirement already satisfied: google-auth<2.0.0dev,>=0.4.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(1.0.1)
Requirement already satisfied: google-auth-httplib2 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(0.0.2)
Requirement already satisfied: google-gax<0.16dev,>=0.15.7 in /home/jenkins/.local/lib/python2.7/site-packages
(from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(0.15.13)
Requirement already satisfied: grpc-google-iam-v1<0.12dev,>=0.11.1 in /home/jenkins/.local/lib/python2.7/site-packages
(from gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(0.11.1)
Requirement already satisfied: cachetools>=2.0.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-auth<2.0.0dev,>=0.4.0->google-cloud-core<0.26dev,>=0.25.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(2.0.0)
Requirement already satisfied: future<0.17dev,>=0.16.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(0.16.0)
Requirement already satisfied: ply==3.8 in /home/jenkins/.local/lib/python2.7/site-packages
(from google-gax<0.16dev,>=0.15.7->gapic-google-cloud-pubsub-v1<0.16dev,>=0.15.0->google-cloud-pubsub==0.26.0->apache-beam==2.5.0.dev0)
(3.8)
hdfs 2.1.0 requires docopt, which is not installed.
hdfs 2.1.0 requires requests>=2.7.0, which is not installed.
hdfs 2.1.0 requires six>=1.9.0, which is not installed.
apache-beam 2.5.0.dev0 requires avro<2.0.0,>=1.8.1, which is not installed.
apache-beam 2.5.0.dev0 requires crcmod<2.0,>=1.7, which is not installed.
apache-beam 2.5.0.dev0 requires dill==0.2.6, which is not installed.
apache-beam 2.5.0.dev0 requires futures<4.0.0,>=3.1.1, which is not installed.
apache-beam 2.5.0.dev0 requires httplib2<0.10,>=0.8, which is not installed.
apache-beam 2.5.0.dev0 requires mock<3.0.0,>=1.0.1, which is not installed.
apache-beam 2.5.0.dev0 requires oauth2client<5,>=2.0.1, which is not installed.
apache-beam 2.5.0.dev0 requires protobuf<4,>=3.5.0.post1, which is not installed.
apache-beam 2.5.0.dev0 requires pyvcf<0.7.0,>=0.6.8, which is not installed.
apache-beam 2.5.0.dev0 requires pyyaml<4.0.0,>=3.12, which is not installed.
apache-beam 2.5.0.dev0 requires six<1.12,>=1.9, which is not installed.
apache-beam 2.5.0.dev0 requires typing<3.7.0,>=3.6.0, which is not installed.
grpcio 1.10.0 requires enum34>=1.0.4, which is not installed.
grpcio 1.10.0 requires futures>=2.2.0, which is not installed.
grpcio 1.10.0 requires protobuf>=3.5.0.post1, which is not installed.
grpcio 1.10.0 requires six>=1.5.2, which is not installed.
Installing collected packages: grpcio, hdfs, pytz, nose, apache-beam
  Found existing installation: grpcio 1.3.5
    Not uninstalling grpcio at /home/jenkins/.local/lib/python2.7/site-packages, outside environment
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env>
    Can't uninstall 'grpcio'. No files were found to uninstall.
  The scripts hdfscli and hdfscli-avro are installed in '<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/bin'>
which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  The scripts nosetests and nosetests-2.7 are installed in '<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env/bin'>
which is not on PATH.
  Consider adding this directory to PATH or, if you prefer to suppress this warning, use --no-warn-script-location.
  Found existing installation: apache-beam 2.5.0.dev0
    Not uninstalling apache-beam at /home/jenkins/jenkins-slave/workspace/beam_PerformanceTests_TextIOIT/src/sdks/python,
outside environment <https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/.env>
    Can't uninstall 'apache-beam'. No files were found to uninstall.
  Running setup.py develop for apache-beam
Successfully installed apache-beam grpcio-1.10.0 hdfs-2.1.0 nose-1.3.7 pytz-2018.3
[beam_PerformanceTests_Spark] $ /bin/bash -xe /tmp/jenkins4405703900285322808.sh
+ .env/bin/python PerfKitBenchmarker/pkb.py --project=apache-beam-testing --dpb_log_level=INFO
--maven_binary=/home/jenkins/tools/maven/latest/bin/mvn --bigquery_table=beam_performance.pkb_results
--temp_dir=<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/> --official=true
--benchmarks=dpb_wordcount_benchmark --dpb_wordcount_input=/etc/hosts --config_override=dpb_wordcount_benchmark.dpb_service.service_type=dataproc
2018-04-01 00:01:27,173 f6f236ae MainThread INFO     Verbose logging to: <https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/runs/f6f236ae/pkb.log>
2018-04-01 00:01:27,174 f6f236ae MainThread INFO     PerfKitBenchmarker version: v1.12.0-454-g8b295f3
2018-04-01 00:01:27,174 f6f236ae MainThread INFO     Flag values:
--temp_dir=<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/>
--maven_binary=/home/jenkins/tools/maven/latest/bin/mvn
--project=apache-beam-testing
--bigquery_table=beam_performance.pkb_results
--dpb_wordcount_input=/etc/hosts
--official
--dpb_log_level=INFO
--benchmarks=dpb_wordcount_benchmark
--config_override=dpb_wordcount_benchmark.dpb_service.service_type=dataproc
2018-04-01 00:01:27,503 f6f236ae MainThread WARNING  The key "flags" was not in the default
config, but was in user overrides. This may indicate a typo.
2018-04-01 00:01:27,503 f6f236ae MainThread INFO     Initializing the edw service decoder
2018-04-01 00:01:27,574 f6f236ae MainThread INFO     Benchmark run statuses:
----------------------------------------------------------------------------
Name                     UID                       Status   Failed Substatus
----------------------------------------------------------------------------
dpb_wordcount_benchmark  dpb_wordcount_benchmark0  SKIPPED                  
----------------------------------------------------------------------------
Success rate: 0.00% (0/1)
2018-04-01 00:01:27,574 f6f236ae MainThread INFO     Complete logs can be found at: <https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/runs/f6f236ae/pkb.log>
2018-04-01 00:01:27,574 f6f236ae MainThread INFO     Completion statuses can be found at:
<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/runs/f6f236ae/completion_statuses.json>
Traceback (most recent call last):
  File "PerfKitBenchmarker/pkb.py", line 21, in <module>
    sys.exit(Main())
  File "<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/PerfKitBenchmarker/perfkitbenchmarker/pkb.py",>
line 952, in Main
    return RunBenchmarks()
  File "<https://builds.apache.org/job/beam_PerformanceTests_Spark/ws/PerfKitBenchmarker/perfkitbenchmarker/pkb.py",>
line 868, in RunBenchmarks
    if FLAGS.run_with_pdb and FLAGS.run_processes == 1:
  File "/home/jenkins/.local/lib/python2.7/site-packages/absl/flags/_flagvalues.py", line
477, in __getattr__
    raise AttributeError(name)
AttributeError: run_with_pdb
Build step 'Execute shell' marked build as failure

Mime
View raw message