beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "ASF GitHub Bot (JIRA)" <j...@apache.org>
Subject [jira] [Work logged] (BEAM-3873) Current version of commons-compress is DOS vulnerable CVE-2018-1324
Date Mon, 19 Mar 2018 16:39:00 GMT

     [ https://issues.apache.org/jira/browse/BEAM-3873?focusedWorklogId=81914&page=com.atlassian.jira.plugin.system.issuetabpanels:worklog-tabpanel#worklog-81914
]

ASF GitHub Bot logged work on BEAM-3873:
----------------------------------------

                Author: ASF GitHub Bot
            Created on: 19/Mar/18 16:38
            Start Date: 19/Mar/18 16:38
    Worklog Time Spent: 10m 
      Work Description: lukecwik commented on a change in pull request #4889: [BEAM-3873]
Current version of commons-compress is DOS vulnerable CVE-2018-1324
URL: https://github.com/apache/beam/pull/4889#discussion_r175501811
 
 

 ##########
 File path: pom.xml
 ##########
 @@ -163,8 +163,8 @@
     <os-maven-plugin.version>1.5.0.Final</os-maven-plugin.version>
     <groovy-maven-plugin.version>2.0</groovy-maven-plugin.version>
     <license-maven-plugin.version>1.14</license-maven-plugin.version>
-    <maven-surefire-plugin.version>2.20.1</maven-surefire-plugin.version>
-    <maven-failsafe-plugin.version>2.20.1</maven-failsafe-plugin.version>
+    <maven-surefire-plugin.version>2.21.0</maven-surefire-plugin.version>
 
 Review comment:
   Can you update build.gradle to match this version:
   https://github.com/apache/beam/blob/d8cb0e6098370dc5059834ea82c5f6fa22f6a91b/build.gradle#L159

----------------------------------------------------------------
This is an automated message from the Apache Git Service.
To respond to the message, please log on GitHub and use the
URL above to go to the specific comment.
 
For queries about this service, please contact Infrastructure at:
users@infra.apache.org


Issue Time Tracking
-------------------

    Worklog Id:     (was: 81914)
    Time Spent: 1.5h  (was: 1h 20m)

> Current version of commons-compress is DOS vulnerable CVE-2018-1324
> -------------------------------------------------------------------
>
>                 Key: BEAM-3873
>                 URL: https://issues.apache.org/jira/browse/BEAM-3873
>             Project: Beam
>          Issue Type: Bug
>          Components: build-system, sdk-java-core
>    Affects Versions: 2.3.0, 2.4.0
>            Reporter: Ismaël Mejía
>            Assignee: Ismaël Mejía
>            Priority: Major
>          Time Spent: 1.5h
>  Remaining Estimate: 0h
>
> The commons-compress version of the library used by Beam has a security vulnerability.
For more details see [CVE-2018-1324|https://www.cvedetails.com/cve/CVE-2018-1324/]



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)

Mime
View raw message