beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Apache Jenkins Server <jenk...@builds.apache.org>
Subject Build failed in Jenkins: beam_PerformanceTests_Python #1399
Date Fri, 07 Sep 2018 11:44:49 GMT
See <https://builds.apache.org/job/beam_PerformanceTests_Python/1399/display/redirect>

------------------------------------------
GitHub pull request #6346 of commit a2744a33771f565c15fa52bad0f94b4e31a32a9a, no merge conflicts.
Setting status of a2744a33771f565c15fa52bad0f94b4e31a32a9a to PENDING with url https://builds.apache.org/job/beam_PerformanceTests_Python/1399/
and message: 'Build started for merge commit.'
Using context: Python SDK Performance Test
[EnvInject] - Loading node environment variables.
Building remotely on beam7 (beam) in workspace <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/>
 > git rev-parse --is-inside-work-tree # timeout=10
Fetching changes from the remote Git repository
 > git config remote.origin.url https://github.com/apache/beam.git # timeout=10
Fetching upstream changes from https://github.com/apache/beam.git
 > git --version # timeout=10
 > git fetch --tags --progress https://github.com/apache/beam.git +refs/heads/*:refs/remotes/origin/*
+refs/pull/6346/*:refs/remotes/origin/pr/6346/*
 > git rev-parse refs/remotes/origin/pr/6346/merge^{commit} # timeout=10
 > git rev-parse refs/remotes/origin/origin/pr/6346/merge^{commit} # timeout=10
Checking out Revision 4d2e145d67f66fff7343febe026adc9be7488661 (refs/remotes/origin/pr/6346/merge)
 > git config core.sparsecheckout # timeout=10
 > git checkout -f 4d2e145d67f66fff7343febe026adc9be7488661
Commit message: "Merge a2744a33771f565c15fa52bad0f94b4e31a32a9a into c34c367f5da6f9bef8a46471195470923a201af9"
First time build. Skipping changelog.
Cleaning workspace
 > git rev-parse --verify HEAD # timeout=10
Resetting working tree
 > git reset --hard # timeout=10
 > git clean -fdx # timeout=10
[EnvInject] - Executing scripts and injecting environment variables after the SCM step.
[EnvInject] - Injecting as environment variables the properties content 
SPARK_LOCAL_IP=127.0.0.1

[EnvInject] - Variables injected successfully.
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins3158700796239671106.sh
+ rm -rf <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/PerfKitBenchmarker>
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins8347101356608773931.sh
+ rm -rf <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env>
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins4109572088161054467.sh
+ rm -rf <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.perfkit_env>
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins7888033241425676746.sh
+ virtualenv --version
15.0.1
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins567951048799477072.sh
+ virtualenv <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env>
--no-site-packages
New python executable in <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env/bin/python2>
Also creating executable in <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env/bin/python>
Installing setuptools, pkg_resources, pip, wheel...done.
Running virtualenv with interpreter /usr/bin/python2
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins2155887987380593673.sh
+ . <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env/bin/activate>
++ deactivate nondestructive
++ unset -f pydoc
++ '[' -z '' ']'
++ '[' -z '' ']'
++ '[' -n /bin/bash ']'
++ hash -r
++ '[' -z '' ']'
++ unset VIRTUAL_ENV
++ '[' '!' nondestructive = nondestructive ']'
++ VIRTUAL_ENV=<https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env>
++ export VIRTUAL_ENV
++ _OLD_VIRTUAL_PATH=/home/jenkins/tools/java/latest1.8/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
++ PATH=<https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env/bin>:/home/jenkins/tools/java/latest1.8/bin:/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/usr/local/games
++ export PATH
++ '[' -z '' ']'
++ '[' -z '' ']'
++ _OLD_VIRTUAL_PS1=
++ '[' x '!=' x ']'
+++ basename <https://builds.apache.org/job/beam_PerformanceTests_Python/ws/env/.beam_env>
++ PS1='(.beam_env) '
++ export PS1
++ alias pydoc
++ '[' -n /bin/bash ']'
++ hash -r
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins57871251173521881.sh
+ which python pip
/usr/bin/python
/usr/local/bin/pip
[beam_PerformanceTests_Python] $ /bin/bash -xe /tmp/jenkins4819924681319078626.sh
+ pip install --upgrade setuptools pip grpcio-tools==1.3.5
Collecting setuptools
  Using cached https://files.pythonhosted.org/packages/66/e8/570bb5ca88a8bcd2a1db9c6246bb66615750663ffaaeada95b04ffe74e12/setuptools-40.2.0-py2.py3-none-any.whl
Collecting pip
  Using cached https://files.pythonhosted.org/packages/5f/25/e52d3f31441505a5f3af41213346e5b6c221c9e086a166f3703d2ddaf940/pip-18.0-py2.py3-none-any.whl
Collecting grpcio-tools==1.3.5
  Using cached https://files.pythonhosted.org/packages/05/f6/0296e29b1bac6f85d2a8556d48adf825307f73109a3c2c17fb734292db0a/grpcio_tools-1.3.5-cp27-cp27mu-manylinux1_x86_64.whl
Requirement not upgraded as not directly required: grpcio>=1.3.5 in /home/jenkins/.local/lib/python2.7/site-packages
(from grpcio-tools==1.3.5) (1.13.0)
Requirement not upgraded as not directly required: protobuf>=3.2.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from grpcio-tools==1.3.5) (3.6.0)
Requirement not upgraded as not directly required: six>=1.5.2 in /usr/local/lib/python2.7/dist-packages
(from grpcio>=1.3.5->grpcio-tools==1.3.5) (1.11.0)
Requirement not upgraded as not directly required: enum34>=1.0.4 in /usr/local/lib/python2.7/dist-packages
(from grpcio>=1.3.5->grpcio-tools==1.3.5) (1.1.6)
Requirement not upgraded as not directly required: futures>=2.2.0 in /home/jenkins/.local/lib/python2.7/site-packages
(from grpcio>=1.3.5->grpcio-tools==1.3.5) (3.2.0)
gapic-google-cloud-pubsub-v1 0.15.4 has requirement oauth2client<4.0dev,>=2.0.0, but
you'll have oauth2client 4.1.2 which is incompatible.
proto-google-cloud-datastore-v1 0.90.4 has requirement oauth2client<4.0dev,>=2.0.0,
but you'll have oauth2client 4.1.2 which is incompatible.
proto-google-cloud-pubsub-v1 0.15.4 has requirement oauth2client<4.0dev,>=2.0.0, but
you'll have oauth2client 4.1.2 which is incompatible.
googledatastore 7.0.1 has requirement httplib2<0.10,>=0.9.1, but you'll have httplib2
0.11.3 which is incompatible.
googledatastore 7.0.1 has requirement oauth2client<4.0.0,>=2.0.1, but you'll have oauth2client
4.1.2 which is incompatible.
Installing collected packages: setuptools, pip, grpcio-tools
  Found existing installation: setuptools 40.0.0
    Uninstalling setuptools-40.0.0:
      Successfully uninstalled setuptools-40.0.0
  Rolling back uninstall of setuptools
Could not install packages due to an EnvironmentError: [Errno 13] Permission denied: '/usr/local/lib/python2.7/dist-packages/easy_install.py'
Consider using the `--user` option or check the permissions.

You are using pip version 10.0.1, however version 18.0 is available.
You should consider upgrading via the 'pip install --upgrade pip' command.
Build step 'Execute shell' marked build as failure

Mime
View raw message