beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tvalen...@apache.org
Subject [beam] 01/01: Restrict the upper bound for pyhamcrest, since new version does not work on py2.
Date Tue, 07 Jan 2020 17:33:48 GMT
This is an automated email from the ASF dual-hosted git repository.

tvalentyn pushed a commit to branch tvalentyn-patch-1
in repository https://gitbox.apache.org/repos/asf/beam.git

commit 0aa98761b8ae04b0bc571272686450ed7cc16439
Author: tvalentyn <tvalentyn@users.noreply.github.com>
AuthorDate: Tue Jan 7 09:33:27 2020 -0800

    Restrict the upper bound for pyhamcrest, since new version does not work on py2.
---
 sdks/python/setup.py | 3 ++-
 1 file changed, 2 insertions(+), 1 deletion(-)

diff --git a/sdks/python/setup.py b/sdks/python/setup.py
index fcb4fd4..cabaa1f 100644
--- a/sdks/python/setup.py
+++ b/sdks/python/setup.py
@@ -178,7 +178,8 @@ REQUIRED_TEST_PACKAGES = [
     'nose_xunitmp>=0.4.1',
     'pandas>=0.23.4,<0.25',
     'parameterized>=0.6.0,<0.8.0',
-    'pyhamcrest>=1.9,<2.0',
+    # pyhamcrest==1.10.0 requires Py3. Beam still supports Py2.
+    'pyhamcrest>=1.9,<1.10.0',
     'pyyaml>=3.12,<6.0.0',
     'requests_mock>=1.7,<2.0',
     'tenacity>=5.0.2,<6.0',


Mime
View raw message