beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From git-site-r...@apache.org
Subject [beam] branch asf-site updated: Publishing website 2020/02/12 00:10:30 at commit 9165828
Date Wed, 12 Feb 2020 00:10:37 GMT
This is an automated email from the ASF dual-hosted git repository.

git-site-role pushed a commit to branch asf-site
in repository https://gitbox.apache.org/repos/asf/beam.git


The following commit(s) were added to refs/heads/asf-site by this push:
     new ac5d331  Publishing website 2020/02/12 00:10:30 at commit 9165828
ac5d331 is described below

commit ac5d331725200126d9c1a83541ed1a0946d13336
Author: jenkins <builds@apache.org>
AuthorDate: Wed Feb 12 00:10:31 2020 +0000

    Publishing website 2020/02/12 00:10:30 at commit 9165828
---
 .../sdks/java-dependencies/index.html              | 386 +++-------------
 .../sdks/python-dependencies/index.html            | 501 ++-------------------
 2 files changed, 98 insertions(+), 789 deletions(-)

diff --git a/website/generated-content/documentation/sdks/java-dependencies/index.html b/website/generated-content/documentation/sdks/java-dependencies/index.html
index e7523d0..09005a0 100644
--- a/website/generated-content/documentation/sdks/java-dependencies/index.html
+++ b/website/generated-content/documentation/sdks/java-dependencies/index.html
@@ -313,338 +313,60 @@ behavior in the service. If you are using any of these packages in your code, be
 aware that some libraries are not forward-compatible and you may need to pin to
 the listed versions that will be in scope during execution.</p>
 
-<p>To see the compile and runtime dependencies for your Beam SDK version, expand
-the relevant section below.</p>
-
-<details><summary><b>2.9.0</b></summary>
-
-<p>Beam SDK for Java 2.9.0 has the following compile and runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>GroupId</th><th>ArtifactId</th><th>Version</th></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-amqp</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-broker</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-client</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-jaas</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq.tooling</td><td>activemq-junit</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-kahadb-store</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-mqtt</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.apex</td><td>apex-common</td><td>3.7.0</td></tr>
-  <tr><td>org.apache.apex</td><td>apex-engine</td><td>3.7.0</td></tr>
-  <tr><td>args4j</td><td>args4j</td><td>2.33</td></tr>
-  <tr><td>org.apache.avro</td><td>avro</td><td>1.8.2</td></tr>
-  <tr><td>com.google.cloud.bigdataoss</td><td>gcsio</td><td>1.9.0</td></tr>
-  <tr><td>com.google.cloud.bigdataoss</td><td>util</td><td>1.9.0</td></tr>
-  <tr><td>com.google.cloud.bigtable</td><td>bigtable-client-core</td><td>1.4.0</td></tr>
-  <tr><td>net.bytebuddy</td><td>byte-buddy</td><td>1.9.3</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-compress</td><td>1.16.1</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-csv</td><td>1.4</td></tr>
-  <tr><td>commons-io</td><td>commons-io</td><td>1.3.2</td></tr>
-  <tr><td>commons-io</td><td>commons-io</td><td>2.5</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-lang3</td><td>3.6</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-math3</td><td>3.6.1</td></tr>
-  <tr><td>com.google.cloud.datastore</td><td>datastore-v1-proto-client</td><td>1.6.0</td></tr>
-  <tr><td>com.google.errorprone</td><td>error_prone_annotations</td><td>2.0.15</td></tr>
-  <tr><td>com.google.api</td><td>gax-grpc</td><td>1.29.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client</td><td>1.27.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client-jackson2</td><td>1.27.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client-java6</td><td>1.27.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-bigquery</td><td>v2-rev20181104-1.27.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-clouddebugger</td><td>v2-rev20180801-1.27.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-cloudresourcemanager</td><td>v1-rev20181015-1.27.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-dataflow</td><td>v1b3-rev20181107-1.27.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-pubsub</td><td>v1-rev20181105-1.27.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-storage</td><td>v1-rev20181013-1.27.0</td></tr>
-  <tr><td>com.google.auth</td><td>google-auth-library-credentials</td><td>0.10.0</td></tr>
-  <tr><td>com.google.auth</td><td>google-auth-library-oauth2-http</td><td>0.10.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-bigquery</td><td>1.27.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-core</td><td>1.36.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-core-grpc</td><td>1.36.0</td></tr>
-  <tr><td>com.google.cloud.dataflow</td><td>google-cloud-dataflow-java-proto-library-all</td><td>0.5.160304</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-spanner</td><td>0.54.0-beta</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client</td><td>1.27.0</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-jackson</td><td>1.27.0</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-jackson2</td><td>1.27.0</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-protobuf</td><td>1.27.0</td></tr>
-  <tr><td>com.google.oauth-client</td><td>google-oauth-client</td><td>1.27.0</td></tr>
-  <tr><td>com.google.oauth-client</td><td>google-oauth-client-java6</td><td>1.27.0</td></tr>
-  <tr><td>io.grpc</td><td>grpc-all</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-auth</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-core</td><td>1.13.1</td></tr>
-  <tr><td>com.google.api.grpc</td><td>grpc-google-cloud-pubsub-v1</td><td>1.18.0</td></tr>
-  <tr><td>io.grpc</td><td>grpc-netty</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-protobuf-lite</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-protobuf</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-stub</td><td>1.13.1</td></tr>
-  <tr><td>com.google.guava</td><td>guava</td><td>20.0</td></tr>
-  <tr><td>com.google.guava</td><td>guava-testlib</td><td>20.0</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-client</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-common</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-hdfs</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-mapreduce-client-core</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-minicluster</td><td>2.7.3</td></tr>
-  <tr><td>org.hamcrest</td><td>hamcrest-core</td><td>1.3</td></tr>
-  <tr><td>org.hamcrest</td><td>hamcrest-library</td><td>1.3</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-annotations</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-core</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-databind</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.dataformat</td><td>jackson-dataformat-cbor</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.dataformat</td><td>jackson-dataformat-yaml</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.datatype</td><td>jackson-datatype-joda</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.module</td><td>jackson-module-scala_2.11</td><td>2.9.5</td></tr>
-  <tr><td>javax.xml.bind</td><td>jaxb-api</td><td>2.2.12</td></tr>
-  <tr><td>joda-time</td><td>joda-time</td><td>2.4</td></tr>
-  <tr><td>junit</td><td>junit</td><td>4.12</td></tr>
-  <tr><td>org.apache.kafka</td><td>kafka_2.11</td><td>1.0.0</td></tr>
-  <tr><td>org.apache.kafka</td><td>kafka-clients</td><td>1.0.0</td></tr>
-  <tr><td>org.apache.apex</td><td>malhar-library</td><td>3.4.0</td></tr>
-  <tr><td>org.mockito</td><td>mockito-core</td><td>1.10.19</td></tr>
-  <tr><td>io.netty</td><td>netty-handler</td><td>4.1.25.Final</td></tr>
-  <tr><td>io.netty</td><td>netty-tcnative-boringssl-static</td><td>2.0.8.Final</td></tr>
-  <tr><td>io.netty</td><td>netty-transport-native-epoll</td><td>4.1.25.Final</td></tr>
-  <tr><td>org.postgresql</td><td>postgresql</td><td>42.2.2</td></tr>
-  <tr><td>org.powermock</td><td>powermock-mockito-release-full</td><td>1.6.4</td></tr>
-  <tr><td>com.google.protobuf</td><td>protobuf-java</td><td>3.6.0</td></tr>
-  <tr><td>com.google.protobuf</td><td>protobuf-java-util</td><td>3.6.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-pubsub-v1</td><td>1.18.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-spanner-admin-database-v1</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-common-protos</td><td>1.12.0</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-api</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-jdk14</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-log4j12</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-simple</td><td>1.7.25</td></tr>
-  <tr><td>org.xerial.snappy</td><td>snappy-java</td><td>1.1.4</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-core_2.11</td><td>2.3.2</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-network-common_2.11</td><td>2.3.2</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-streaming_2.11</td><td>2.3.2</td></tr>
-  <tr><td>org.codehaus.woodstox</td><td>stax2-api</td><td>3.1.4</td></tr>
-  <tr><td>org.codehaus.woodstox</td><td>woodstox-core-asl</td><td>4.4.1</td></tr>
-  <tr><td>com.pholser</td><td>junit-quickcheck-core</td><td>0.8</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.8.0</b></summary>
-
-<p>Beam SDK for Java 2.8.0 has the following compile and runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>GroupId</th><th>ArtifactId</th><th>Version</th></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-amqp</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-broker</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-client</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-jaas</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq.tooling</td><td>activemq-junit</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-kahadb-store</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-mqtt</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.apex</td><td>apex-common</td><td>3.7.0</td></tr>
-  <tr><td>org.apache.apex</td><td>apex-engine</td><td>3.7.0</td></tr>
-  <tr><td>com.google.api</td><td>api-common</td><td>1.6.0</td></tr>
-  <tr><td>args4j</td><td>args4j</td><td>2.33</td></tr>
-  <tr><td>org.apache.avro</td><td>avro</td><td>1.8.2</td></tr>
-  <tr><td>com.google.cloud.bigtable</td><td>bigtable-client-core</td><td>1.4.0</td></tr>
-  <tr><td>net.bytebuddy</td><td>byte-buddy</td><td>1.8.11</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-compress</td><td>1.16.1</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-csv</td><td>1.4</td></tr>
-  <tr><td>commons-io</td><td>commons-io</td><td>1.3.2</td></tr>
-  <tr><td>commons-io</td><td>commons-io</td><td>2.5</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-lang3</td><td>3.6</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-math3</td><td>3.6.1</td></tr>
-  <tr><td>com.google.cloud.datastore</td><td>datastore-v1-proto-client</td><td>1.6.0</td></tr>
-  <tr><td>com.google.errorprone</td><td>error_prone_annotations</td><td>2.0.15</td></tr>
-  <tr><td>com.google.api</td><td>gax-grpc</td><td>1.29.0</td></tr>
-  <tr><td>com.google.cloud.bigdataoss</td><td>gcsio</td><td>1.9.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client-jackson2</td><td>1.24.1</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client-java6</td><td>1.24.1</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client</td><td>1.24.1</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-bigquery</td><td>v2-rev402-1.24.1</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-clouddebugger</td><td>v2-rev253-1.24.1</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-cloudresourcemanager</td><td>v1-rev502-1.24.1</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-dataflow</td><td>v1b3-rev257-1.24.1</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-pubsub</td><td>v1-rev399-1.24.1</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-storage</td><td>v1-rev136-1.24.1</td></tr>
-  <tr><td>com.google.auth</td><td>google-auth-library-credentials</td><td>0.10.0</td></tr>
-  <tr><td>com.google.auth</td><td>google-auth-library-oauth2-http</td><td>0.10.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-core-grpc</td><td>1.36.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-core</td><td>1.36.0</td></tr>
-  <tr><td>com.google.cloud.dataflow</td><td>google-cloud-dataflow-java-proto-library-all</td><td>0.5.160304</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-spanner</td><td>0.54.0-beta</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-jackson2</td><td>1.24.1</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-jackson</td><td>1.24.1</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-protobuf</td><td>1.24.1</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client</td><td>1.24.1</td></tr>
-  <tr><td>com.google.oauth-client</td><td>google-oauth-client-java6</td><td>1.24.1</td></tr>
-  <tr><td>com.google.oauth-client</td><td>google-oauth-client</td><td>1.24.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-all</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-auth</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-core</td><td>1.13.1</td></tr>
-  <tr><td>com.google.api.grpc</td><td>grpc-google-cloud-bigtable-v2</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>grpc-google-cloud-pubsub-v1</td><td>1.18.0</td></tr>
-  <tr><td>io.grpc</td><td>grpc-netty</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-protobuf-lite</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-protobuf</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-stub</td><td>1.13.1</td></tr>
-  <tr><td>com.google.guava</td><td>guava</td><td>20.0</td></tr>
-  <tr><td>com.google.guava</td><td>guava-testlib</td><td>20.0</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-client</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-common</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-hdfs</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-hdfs</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-mapreduce-client-core</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-minicluster</td><td>2.7.3</td></tr>
-  <tr><td>org.hamcrest</td><td>hamcrest-core</td><td>1.3</td></tr>
-  <tr><td>org.hamcrest</td><td>hamcrest-library</td><td>1.3</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-annotations</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-core</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-databind</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.dataformat</td><td>jackson-dataformat-cbor</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.dataformat</td><td>jackson-dataformat-yaml</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.datatype</td><td>jackson-datatype-joda</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.module</td><td>jackson-module-scala_2.11</td><td>2.9.5</td></tr>
-  <tr><td>javax.xml.bind</td><td>jaxb-api</td><td>2.2.12</td></tr>
-  <tr><td>joda-time</td><td>joda-time</td><td>2.4</td></tr>
-  <tr><td>com.pholser</td><td>junit-quickcheck-core</td><td>0.8</td></tr>
-  <tr><td>junit</td><td>junit</td><td>4.12</td></tr>
-  <tr><td>org.apache.kafka</td><td>kafka_2.11</td><td>1.0.0</td></tr>
-  <tr><td>org.apache.kafka</td><td>kafka-clients</td><td>1.0.0</td></tr>
-  <tr><td>org.apache.apex</td><td>malhar-library</td><td>3.4.0</td></tr>
-  <tr><td>org.mockito</td><td>mockito-core</td><td>1.10.19</td></tr>
-  <tr><td>io.netty</td><td>netty-handler</td><td>4.1.25.Final</td></tr>
-  <tr><td>io.netty</td><td>netty-tcnative-boringssl-static</td><td>2.0.8.Final</td></tr>
-  <tr><td>io.netty</td><td>netty-transport-native-epoll</td><td>4.1.25.Final</td></tr>
-  <tr><td>org.postgresql</td><td>postgresql</td><td>42.2.2</td></tr>
-  <tr><td>org.powermock</td><td>powermock-mockito-release-full</td><td>1.6.4</td></tr>
-  <tr><td>com.google.protobuf</td><td>protobuf-java</td><td>3.6.0</td></tr>
-  <tr><td>com.google.protobuf</td><td>protobuf-java-util</td><td>3.6.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-datastore-v1</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-pubsub-v1</td><td>1.18.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-spanner-admin-database-v1</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-common-protos</td><td>1.12.0</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-api</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-jdk14</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-log4j12</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-simple</td><td>1.7.25</td></tr>
-  <tr><td>org.xerial.snappy</td><td>snappy-java</td><td>1.1.4</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-core_2.11</td><td>2.3.1</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-network-common_2.11</td><td>2.3.1</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-streaming_2.11</td><td>2.3.1</td></tr>
-  <tr><td>org.codehaus.woodstox</td><td>stax2-api</td><td>3.1.4</td></tr>
-  <tr><td>com.google.cloud.bigdataoss</td><td>util</td><td>1.9.0</td></tr>
-  <tr><td>org.codehaus.woodstox</td><td>woodstox-core-asl</td><td>4.4.1</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.7.0</b></summary>
-
-<p>Beam SDK for Java 2.7.0 has the following compile and runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>GroupId</th><th>ArtifactId</th><th>Version</th></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-amqp</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-broker</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-client</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-jaas</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq.tooling</td><td>activemq-junit</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-kahadb-store</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.activemq</td><td>activemq-mqtt</td><td>5.13.1</td></tr>
-  <tr><td>org.apache.apex</td><td>apex-common</td><td>3.7.0</td></tr>
-  <tr><td>org.apache.apex</td><td>apex-engine</td><td>3.7.0</td></tr>
-  <tr><td>com.google.api</td><td>api-common</td><td>1.6.0</td></tr>
-  <tr><td>args4j</td><td>args4j</td><td>2.33</td></tr>
-  <tr><td>org.apache.avro</td><td>avro</td><td>1.8.2</td></tr>
-  <tr><td>com.google.cloud.bigtable</td><td>bigtable-client-core</td><td>1.4.0</td></tr>
-  <tr><td>net.bytebuddy</td><td>byte-buddy</td><td>1.8.11</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-compress</td><td>1.16.1</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-csv</td><td>1.4</td></tr>
-  <tr><td>commons-io</td><td>commons-io</td><td>1.3.2</td></tr>
-  <tr><td>commons-io</td><td>commons-io</td><td>2.5</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-lang3</td><td>3.6</td></tr>
-  <tr><td>org.apache.commons</td><td>commons-math3</td><td>3.6.1</td></tr>
-  <tr><td>com.google.cloud.datastore</td><td>datastore-v1-proto-client</td><td>1.6.0</td></tr>
-  <tr><td>com.google.errorprone</td><td>error_prone_annotations</td><td>2.0.15</td></tr>
-  <tr><td>com.google.api</td><td>gax-grpc</td><td>1.29.0</td></tr>
-  <tr><td>com.google.cloud.bigdataoss</td><td>gcsio</td><td>1.9.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client-jackson2</td><td>1.23.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client-java6</td><td>1.23.0</td></tr>
-  <tr><td>com.google.api-client</td><td>google-api-client</td><td>1.23.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-bigquery</td><td>v2-rev374-1.23.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-clouddebugger</td><td>v2-rev233-1.23.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-cloudresourcemanager</td><td>v1-rev477-1.23.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-dataflow</td><td>v1b3-rev221-1.23.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-pubsub</td><td>v1-rev382-1.23.0</td></tr>
-  <tr><td>com.google.apis</td><td>google-api-services-storage</td><td>v1-rev124-1.23.0</td></tr>
-  <tr><td>com.google.auth</td><td>google-auth-library-credentials</td><td>0.10.0</td></tr>
-  <tr><td>com.google.auth</td><td>google-auth-library-oauth2-http</td><td>0.10.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-core-grpc</td><td>1.36.0</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-core</td><td>1.36.0</td></tr>
-  <tr><td>com.google.cloud.dataflow</td><td>google-cloud-dataflow-java-proto-library-all</td><td>0.5.160304</td></tr>
-  <tr><td>com.google.cloud</td><td>google-cloud-spanner</td><td>0.54.0-beta</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-jackson2</td><td>1.23.0</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-jackson</td><td>1.23.0</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client-protobuf</td><td>1.23.0</td></tr>
-  <tr><td>com.google.http-client</td><td>google-http-client</td><td>1.23.0</td></tr>
-  <tr><td>com.google.oauth-client</td><td>google-oauth-client-java6</td><td>1.23.0</td></tr>
-  <tr><td>com.google.oauth-client</td><td>google-oauth-client</td><td>1.23.0</td></tr>
-  <tr><td>io.grpc</td><td>grpc-all</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-auth</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-core</td><td>1.13.1</td></tr>
-  <tr><td>com.google.api.grpc</td><td>grpc-google-cloud-bigtable-v2</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>grpc-google-cloud-pubsub-v1</td><td>1.18.0</td></tr>
-  <tr><td>io.grpc</td><td>grpc-netty</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-protobuf-lite</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-protobuf</td><td>1.13.1</td></tr>
-  <tr><td>io.grpc</td><td>grpc-stub</td><td>1.13.1</td></tr>
-  <tr><td>com.google.guava</td><td>guava</td><td>20.0</td></tr>
-  <tr><td>com.google.guava</td><td>guava-testlib</td><td>20.0</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-client</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-common</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-hdfs</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-hdfs</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-mapreduce-client-core</td><td>2.7.3</td></tr>
-  <tr><td>org.apache.hadoop</td><td>hadoop-minicluster</td><td>2.7.3</td></tr>
-  <tr><td>org.hamcrest</td><td>hamcrest-core</td><td>1.3</td></tr>
-  <tr><td>org.hamcrest</td><td>hamcrest-library</td><td>1.3</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-annotations</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-core</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.core</td><td>jackson-databind</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.dataformat</td><td>jackson-dataformat-cbor</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.dataformat</td><td>jackson-dataformat-yaml</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.datatype</td><td>jackson-datatype-joda</td><td>2.9.5</td></tr>
-  <tr><td>com.fasterxml.jackson.module</td><td>jackson-module-scala_2.11</td><td>2.9.5</td></tr>
-  <tr><td>javax.xml.bind</td><td>jaxb-api</td><td>2.2.12</td></tr>
-  <tr><td>joda-time</td><td>joda-time</td><td>2.4</td></tr>
-  <tr><td>com.pholser</td><td>junit-quickcheck-core</td><td>0.8</td></tr>
-  <tr><td>junit</td><td>junit</td><td>4.12</td></tr>
-  <tr><td>org.apache.kafka</td><td>kafka_2.11</td><td>1.0.0</td></tr>
-  <tr><td>org.apache.kafka</td><td>kafka-clients</td><td>1.0.0</td></tr>
-  <tr><td>org.apache.apex</td><td>malhar-library</td><td>3.4.0</td></tr>
-  <tr><td>org.mockito</td><td>mockito-core</td><td>1.10.19</td></tr>
-  <tr><td>io.netty</td><td>netty-handler</td><td>4.1.25.Final</td></tr>
-  <tr><td>io.netty</td><td>netty-tcnative-boringssl-static</td><td>2.0.8.Final</td></tr>
-  <tr><td>io.netty</td><td>netty-transport-native-epoll</td><td>4.1.25.Final</td></tr>
-  <tr><td>org.postgresql</td><td>postgresql</td><td>42.2.2</td></tr>
-  <tr><td>org.powermock</td><td>powermock-mockito-release-full</td><td>1.6.4</td></tr>
-  <tr><td>com.google.protobuf</td><td>protobuf-java</td><td>3.6.0</td></tr>
-  <tr><td>com.google.protobuf</td><td>protobuf-java-util</td><td>3.6.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-datastore-v1</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-pubsub-v1</td><td>1.18.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-cloud-spanner-admin-database-v1</td><td>0.19.0</td></tr>
-  <tr><td>com.google.api.grpc</td><td>proto-google-common-protos</td><td>1.12.0</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-api</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-jdk14</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-log4j12</td><td>1.7.25</td></tr>
-  <tr><td>org.slf4j</td><td>slf4j-simple</td><td>1.7.25</td></tr>
-  <tr><td>org.xerial.snappy</td><td>snappy-java</td><td>1.1.4</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-core_2.11</td><td>2.3.1</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-network-common_2.11</td><td>2.3.1</td></tr>
-  <tr><td>org.apache.spark</td><td>spark-streaming_2.11</td><td>2.3.1</td></tr>
-  <tr><td>org.codehaus.woodstox</td><td>stax2-api</td><td>3.1.4</td></tr>
-  <tr><td>com.google.cloud.bigdataoss</td><td>util</td><td>1.9.0</td></tr>
-  <tr><td>org.codehaus.woodstox</td><td>woodstox-core-asl</td><td>4.4.1</td></tr>
-</table>
-
-</details>
+<p>Compile and runtime dependencies for your Beam SDK version are listed in <code class="highlighter-rouge">BeamModulePlugin.groovy</code> in the Beam repository. To view them, perform the following steps:</p>
+
+<ol>
+  <li>
+    <p>Open <code class="highlighter-rouge">BeamModulePlugin.groovy</code>.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> https://raw.githubusercontent.com/apache/beam/v&lt;VERSION_NUMBER&gt;/buildSrc/src/main/groovy/org/apache/beam/gradle/BeamModulePlugin.groovy
+</code></pre></div>    </div>
+
+    <p>Replace <code class="highlighter-rouge">&lt;VERSION_NUMBER&gt;</code> with the major.minor.patch version of the SDK. For example, <a href="https://raw.githubusercontent.com/apache/beam/v2.19.0/buildSrc/src/main/groovy/org/apache/beam/gradle/BeamModulePlugin.groovy" target="_blank">https://raw.githubusercontent.com/apache/beam/v2.19.0/buildSrc/src/main/groovy/org/apache/beam/gradle/BeamModulePlugin.groovy</a> will provide the dependencies for the 2.19.0 release.</p>
+  </li>
+  <li>
+    <p>Review the list under <code class="highlighter-rouge">project.ext.library</code>.</p>
+
+    <p><strong>Note:</strong> Some dependencies in the list use version variables, such as <code class="highlighter-rouge">google_auth_version</code>. These variables are defined prior to the <code class="highlighter-rouge">project.ext.library</code> map definition.</p>
+  </li>
+</ol>
+
+<p>You can also retrieve this list by creating a new project through Maven and resolving the dependencies.</p>
+
+<ol>
+  <li>
+    <p>Define the Beam SDK and Java versions for the new project.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> export BEAM_VERSION=2.19.0
+ export JAVA_VERSION=11
+</code></pre></div>    </div>
+  </li>
+  <li>
+    <p>Create the project.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> mvn archetype:generate \
+     -DinteractiveMode=false \
+     -DarchetypeGroupId=org.apache.beam \
+     -DarchetypeArtifactId=beam-sdks-java-maven-archetypes-starter \
+     -DarchetypeVersion=$BEAM_VERSION \
+     -DtargetPlatform=$JAVA_VERSION \
+     -DartifactId=check-pipeline-dependencies \
+     -DgroupId=org.apache.beam.samples
+</code></pre></div>    </div>
+  </li>
+  <li>
+    <p>Change to the new project directory.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> cd check-pipeline-dependencies
+</code></pre></div>    </div>
+  </li>
+  <li>
+    <p>Resolve and list the dependencies.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> mvn dependency:resolve &amp;&amp; mvn -o dependency:list
+</code></pre></div>    </div>
+  </li>
+</ol>
 
 
       </div>
diff --git a/website/generated-content/documentation/sdks/python-dependencies/index.html b/website/generated-content/documentation/sdks/python-dependencies/index.html
index 568470c..8859689 100644
--- a/website/generated-content/documentation/sdks/python-dependencies/index.html
+++ b/website/generated-content/documentation/sdks/python-dependencies/index.html
@@ -313,463 +313,50 @@ behavior in the service. If you are using any of these packages in your code, be
 aware that some libraries are not forward-compatible and you may need to pin to
 the listed versions that will be in scope during execution.</p>
 
-<p>To see the compile and runtime dependencies for your Beam SDK version, expand
-the relevant section below.</p>
-
-<details><summary><b>2.17.0</b></summary>
-
-<p>Beam SDK for Python 2.17.0 has the following compile and runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-<tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>cachetools</td><td>&gt;=3.1.0,&lt;4</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.3.0,&lt;0.3.1</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>funcsigs</td><td>&gt;=1.0.2,&lt;2; python_version &lt; "3.0"</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.28,&lt;0.5.29</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.18.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>&gt;=0.31.1,&lt;1.1.0</td></tr>
-  <tr><td>google-cloud-core</td><td>&gt;=0.28.1,&lt;2</td></tr>
-  <tr><td>google-cloud-datastore</td><td>&gt;=1.7.1,&lt;1.8.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>&gt;=0.39.0,&lt;1.1.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.12.1,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.12.0</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4; python_version &lt; "3.0"</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.15.1,&lt;0.16.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;2</td></tr>
-  <tr><td>pymongo</td><td>&gt;=3.8.0,&lt;4.0.0</td></tr>
-  <tr><td>python-dateutil</td><td>&gt;=2.8.0,&lt;3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.16.0</b></summary>
-
-<p>Beam SDK for Python 2.16.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>cachetools</td><td>&gt;=3.1.0,&lt;4</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.3.0,&lt;0.3.1</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>funcsigs</td><td>&gt;=1.0.2,&lt;2; python_version &lt; "3.0"</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.28,&lt;0.5.29</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.18.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>&gt;=0.31.1,&lt;1.1.0</td></tr>
-  <tr><td>google-cloud-core</td><td>&gt;=0.28.1,&lt;2</td></tr>
-  <tr><td>google-cloud-datastore</td><td>&gt;=1.7.1,&lt;1.8.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>&gt;=0.39.0,&lt;1.1.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.12.1,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.12.0</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4; python_version &lt; "3.0"</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.15.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;2</td></tr>
-  <tr><td>pymongo</td><td>&gt;=3.8.0,&lt;4.0.0</td></tr>
-  <tr><td>python-dateutil</td><td>&gt;=2.8.0,&lt;3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.15.0</b></summary>
-
-<p>Beam SDK for Python 2.15.0 has the following compile and
-  runtime dependencies.</p>
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>cachetools</td><td>&gt;=3.1.0,&lt;4</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.28,&lt;0.5.29</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.18.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>&gt;=0.31.1,&lt;0.33.0</td></tr>
-  <tr><td>google-cloud-core</td><td>&gt;=0.28.1,&lt;2</td></tr>
-  <tr><td>google-cloud-datastore</td><td>&gt;=1.7.1,&lt;1.8.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>&gt;=0.39.0,&lt;0.40.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.12.0</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4; python_version &lt; "3.0"</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.15.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;2</td></tr>
-  <tr><td>pymongo</td><td>&gt;=3.8.0,&lt;4.0.0</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.14.0</b></summary>
-
-<p>Beam SDK for Python 2.14.0 has the following compile and
-  runtime dependencies.</p>
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>cachetools</td><td>&gt;=3.1.0,&lt;4</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.28,&lt;0.5.29</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>&gt;=0.31.1,&lt;0.33.0</td></tr>
-  <tr><td>google-cloud-core</td><td>&gt;=0.28.1,&lt;0.30.0</td></tr>
-  <tr><td>google-cloud-datastore</td><td>&gt;=1.7.1,&lt;1.8.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>&gt;=0.39.0,&lt;0.40.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.12.0</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4; python_version &lt; "3.0"</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.15.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
-  <tr><td>pymongo</td><td>&gt;=3.8.0,&lt;4.0.0</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.13.0</b></summary>
-
-<p>Beam SDK for Python 2.13.0 has the following compile and
-  runtime dependencies.</p> 
- 
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>cachetools</td><td>&gt;=3.1.0,&lt;4</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.28,&lt;0.5.29</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>&gt;=0.31.1,&lt;0.33.0</td></tr>
-  <tr><td>google-cloud-core</td><td>&gt;=0.28.1,&lt;0.30.0</td></tr>
-  <tr><td>google-cloud-datastore</td><td>&gt;=1.7.1,&lt;1.8.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>&gt;=0.39.0,&lt;0.40.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.12.0</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4; python_version &lt; "3.0"</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.14.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.12.0</b></summary>
-
-<p>Beam SDK for Python 2.12.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.26,&lt;0.5.27</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>==0.31.1</td></tr>
-  <tr><td>google-cloud-core</td><td>==0.28.1</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.39.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.12.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.11.0</b></summary>
-
-<p>Beam SDK for Python 2.11.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.2.0,&lt;4.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.26,&lt;0.5.27</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
-  <tr><td>google-cloud-bigtable</td><td>==0.31.1</td></tr>
-  <tr><td>google-cloud-core</td><td>==0.28.1</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.39.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.12.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.10.0</b></summary>
-
-<p>Beam SDK for Python 2.10.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro-python3</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &gt;= "3.0"</td></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0; python_version &lt; "3.0"</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.9,&lt;0.2.10</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4,&lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.1.1,&lt;4.0.0</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.23,&lt;=0.5.24</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0,&lt;1.7.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.39.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1,&lt;7.1; python_version &lt; "3.0"</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;4</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pyarrow</td><td>&gt;=0.11.1,&lt;0.12.0; python_version &gt;= "3.0" or platform_system != "Windows"</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0; python_version &lt; "3.5.0"</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.9.0</b></summary>
-
-<p>Beam SDK for Python 2.9.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1, &lt;2.0.0</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7, &lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.6, &lt;=0.2.8.2</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4, &lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0, &lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.1.1, &lt;4.0.0</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.23, &lt;0.5.24</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.35.4</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>&gt;=1.6.0, &lt;1.7.0</td></tr>
-  <tr><td>googledatastore</td><td>&gt;=7.0.1, &lt;7.1</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8, &lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0, &lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8, &lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1, &lt;3.0.0</td></tr>
-  <tr><td>nose</td><td>&gt;=1.3.7</td></tr>
-  <tr><td>numpy</td><td>&gt;=1.14.3, &lt;2</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1, &lt;4</td></tr>
-  <tr><td>parameterized</td><td>&gt;=0.6.0, &lt;0.7.0</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0, &lt;0.90.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1, &lt;4</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0, &lt;1.3</td></tr>
-  <tr><td>pyhamcrest</td><td>&gt;=1.9, &lt;2.0</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3, &lt;=2018.4</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12, &lt;4.0.0</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8, &lt;0.7.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0, &lt;3.7.0</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.8.0</b></summary>
-
-<p>Beam SDK for Python 2.8.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1, &lt;2.0.0</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7, &lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.6, &lt;=0.2.8.2</td></tr>
-  <tr><td>fastavro</td><td>&gt;=0.21.4, &lt;0.22</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0, &lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.1.1, &lt;4.0.0</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.18, &lt;0.5.20</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.26.0</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>==0.25.0</td></tr>
-  <tr><td>googledatastore</td><td>==7.0.1</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8, &lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0, &lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8, &lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1, &lt;3.0.0</td></tr>
-  <tr><td>nose</td><td>&gt;=1.3.7</td></tr>
-  <tr><td>numpy</td><td>&gt;=1.14.3, &lt;2</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1, &lt;5</td></tr>
-  <tr><td>parameterized</td><td>&gt;=0.6.0, &lt;0.7.0</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0, &lt;0.90.4</td></tr>
-  <tr><td>proto-google-cloud-pubsub-v1</td><td>==0.15.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1, &lt;4</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0, &lt;1.3</td></tr>
-  <tr><td>pyhamcrest</td><td>&gt;=1.9, &lt;2.0</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3, &lt;=2018.4</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12, &lt;4.0.0</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8, &lt;0.7.0</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0, &lt;3.7.0</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.7.0</b></summary>
-
-<p>Beam SDK for Python 2.7.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1, &lt;2.0.0</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7, &lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.6, &lt;=0.2.8.2</td></tr>
-  <tr><td>fastavro</td><td>==0.19.7</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0, &lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.1.1, &lt;4.0.0</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.18, &lt;0.5.20</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.26.0</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>==0.25.0</td></tr>
-  <tr><td>googledatastore</td><td>==7.0.1</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8, &lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0, &lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8, &lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1, &lt;3.0.0</td></tr>
-  <tr><td>nose</td><td>&gt;=1.3.7</td></tr>
-  <tr><td>numpy</td><td>&gt;=1.14.3, &lt;2</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1, &lt;5</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0, &lt;0.90.4</td></tr>
-  <tr><td>proto-google-cloud-pubsub-v1</td><td>==0.15.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1, &lt;4</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0, &lt;1.3</td></tr>
-  <tr><td>pyhamcrest</td><td>&gt;=1.9, &lt;2.0</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3, &lt;=2018.4</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12, &lt;4.0.0</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8, &lt;0.7.0</td></tr>
-  <tr><td>six</td><td>&gt;=1.9, &lt;1.12</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0, &lt;3.7.0</td></tr>
-</table>
-
-</details>
-
-<details><summary><b>2.6.0</b></summary>
-
-<p>Beam SDK for Python 2.6.0 has the following compile and
-  runtime dependencies.</p>
-
-<table class="table-bordered table-striped">
-  <tr><th>Package</th><th>Version</th></tr>
-  <tr><td>avro</td><td>&gt;=1.8.1,&lt;2.0.0</td></tr>
-  <tr><td>crcmod</td><td>&gt;=1.7,&lt;2.0</td></tr>
-  <tr><td>dill</td><td>&gt;=0.2.6,&lt;=0.2.8.2</td></tr>
-  <tr><td>future</td><td>&gt;=0.16.0,&lt;1.0.0</td></tr>
-  <tr><td>futures</td><td>&gt;=3.1.1,&lt;4.0.0</td></tr>
-  <tr><td>google-apitools</td><td>&gt;=0.5.18,&lt;=0.5.20</td></tr>
-  <tr><td>google-cloud-bigquery</td><td>==0.25.0</td></tr>
-  <tr><td>google-cloud-pubsub</td><td>==0.26.0</td></tr>
-  <tr><td>googledatastore</td><td>==7.0.1</td></tr>
-  <tr><td>grpcio</td><td>&gt;=1.8,&lt;2</td></tr>
-  <tr><td>hdfs</td><td>&gt;=2.1.0,&lt;3.0.0</td></tr>
-  <tr><td>httplib2</td><td>&gt;=0.8,&lt;=0.11.3</td></tr>
-  <tr><td>mock</td><td>&gt;=1.0.1,&lt;3.0.0</td></tr>
-  <tr><td>oauth2client</td><td>&gt;=2.0.1,&lt;5</td></tr>
-  <tr><td>proto-google-cloud-datastore-v1</td><td>&gt;=0.90.0,&lt;=0.90.4</td></tr>
-  <tr><td>proto-google-cloud-pubsub-v1</td><td>==0.15.4</td></tr>
-  <tr><td>protobuf</td><td>&gt;=3.5.0.post1,&lt;4</td></tr>
-  <tr><td>pydot</td><td>&gt;=1.2.0,&lt;1.3</td></tr>
-  <tr><td>pytz</td><td>&gt;=2018.3,&lt;=2018.4</td></tr>
-  <tr><td>pyvcf</td><td>&gt;=0.6.8,&lt;0.7.0</td></tr>
-  <tr><td>pyyaml</td><td>&gt;=3.12,&lt;4.0.0</td></tr>
-  <tr><td>six</td><td>&gt;=1.9,&lt;1.12</td></tr>
-  <tr><td>typing</td><td>&gt;=3.6.0,&lt;3.7.0</td></tr>
-</table>
-
-</details>
+<p>Dependencies for your Beam SDK version are listed in <code class="highlighter-rouge">setup.py</code> in the Beam repository. To view them, perform the following steps:</p>
+
+<ol>
+  <li>
+    <p>Open <code class="highlighter-rouge">setup.py</code>.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> https://raw.githubusercontent.com/apache/beam/v&lt;VERSION_NUMBER&gt;/sdks/python/setup.py
+</code></pre></div>    </div>
+
+    <p>Replace <code class="highlighter-rouge">&lt;VERSION_NUMBER&gt;</code> with the major.minor.patch version of the SDK. For example, <a href="https://raw.githubusercontent.com/apache/beam/v2.19.0/sdks/python/setup.py" target="_blank">https://raw.githubusercontent.com/apache/beam/v2.19.0/sdks/python/setup.py</a> will provide the dependencies for the 2.19.0 release.</p>
+  </li>
+  <li>
+    <p>Review the core dependency list under <code class="highlighter-rouge">REQUIRED_PACKAGES</code>.</p>
+
+    <p><strong>Note:</strong> If you require <a href="/get-started/quickstart-py#extra-requirements">extra features</a> such as <code class="highlighter-rouge">gcp</code> or <code class="highlighter-rouge">test</code>, you should review the lists under <code class="highlighter-rouge">REQUIRED_TEST_PACKAGES</code>, <code class="highlighter-rouge">GCP_REQUIREMENTS</code>, or <code class="highlighter-rouge">INTERACTIVE_BEAM</code> for additional dependencies.</p>
+  </li>
+</ol>
+
+<p>You can also retrieve the dependency list from the command line using the following process:</p>
+
+<ol>
+  <li>
+    <p>Create a clean virtual environment on your local machine.</p>
+
+    <p>Python 3:</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code>$ python3 -m venv env &amp;&amp; source env/bin/activate
+</code></pre></div>    </div>
+
+    <p>Python 2:</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code>$ pip install virtualenv &amp;&amp; virtualenv env &amp;&amp; source env/bin/activate
+</code></pre></div>    </div>
+  </li>
+  <li>
+    <p><a href="/get-started/quickstart-py/#download-and-install">Install the Beam Python SDK</a>.</p>
+  </li>
+  <li>
+    <p>Retrieve the list of dependencies.</p>
+
+    <div class="highlighter-rouge"><div class="highlight"><pre class="highlight"><code> $ pip install pipdeptree &amp;&amp; pipdeptree -p apache-beam
+</code></pre></div>    </div>
+  </li>
+</ol>
 
       </div>
     </div>


Mime
View raw message