beam-commits mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From git-site-r...@apache.org
Subject [beam] branch asf-site updated: Publishing website 2020/12/08 06:02:52 at commit 31716b0
Date Tue, 08 Dec 2020 06:03:19 GMT
This is an automated email from the ASF dual-hosted git repository.

git-site-role pushed a commit to branch asf-site
in repository https://gitbox.apache.org/repos/asf/beam.git


The following commit(s) were added to refs/heads/asf-site by this push:
     new 4a521b0  Publishing website 2020/12/08 06:02:52 at commit 31716b0
4a521b0 is described below

commit 4a521b044a713d4eee1cf68c86d32099663f16ef
Author: jenkins <builds@apache.org>
AuthorDate: Tue Dec 8 06:02:52 2020 +0000

    Publishing website 2020/12/08 06:02:52 at commit 31716b0
---
 website/generated-content/documentation/index.xml                      | 2 +-
 website/generated-content/documentation/programming-guide/index.html   | 2 +-
 .../documentation/sdks/python-dependencies/index.html                  | 3 +--
 website/generated-content/sitemap.xml                                  | 2 +-
 4 files changed, 4 insertions(+), 5 deletions(-)

diff --git a/website/generated-content/documentation/index.xml b/website/generated-content/documentation/index.xml
index 38831bf..1945012 100644
--- a/website/generated-content/documentation/index.xml
+++ b/website/generated-content/documentation/index.xml
@@ -2642,7 +2642,7 @@ how to implement Beam concepts in your pipelines.&lt;/p>
 &lt;li data-type="language-py">Python SDK&lt;/li>
 &lt;/ul>
 &lt;/nav>
-&lt;p class="language-py">The Python SDK supports Python 2.7, 3.5, 3.6, and 3.7. New
Python SDK releases will stop supporting Python 2.7 in 2020 (&lt;a href="https://issues.apache.org/jira/browse/BEAM-8371">BEAM-8371&lt;/a>).
For best results, use Beam with Python 3.&lt;/p>
+&lt;p class="language-py">The Python SDK supports Python 3.6, 3.7, and 3.8. Beam 2.24.0
was the last Python SDK release to support Python 2 and 3.5.&lt;/p>
 &lt;h2 id="overview">1. Overview&lt;/h2>
 &lt;p>To use Beam, you need to first create a driver program using the classes in
one
 of the Beam SDKs. Your driver program &lt;em>defines&lt;/em> your pipeline,
including all of
diff --git a/website/generated-content/documentation/programming-guide/index.html b/website/generated-content/documentation/programming-guide/index.html
index f469c08..2c39afd 100644
--- a/website/generated-content/documentation/programming-guide/index.html
+++ b/website/generated-content/documentation/programming-guide/index.html
@@ -7,7 +7,7 @@ the Beam SDK classes to build and test your pipeline. It is not intended as
an
 exhaustive reference, but as a language-agnostic, high-level guide to
 programmatically building your Beam pipeline. As the programming guide is filled
 out, the text will include code samples in multiple languages to help illustrate
-how to implement Beam concepts in your pipelines.</p><nav class=language-switcher><strong>Adapt
for:</strong><ul><li data-type=language-java class=active>Java SDK</li><li
data-type=language-py>Python SDK</li></ul></nav><p class=language-py>The
Python SDK supports Python 2.7, 3.5, 3.6, and 3.7. New Python SDK releases will stop supporting
Python 2.7 in 2020 (<a href=https://issues.apache.org/jira/browse/BEAM-8371>BEAM-8371</a>).
For best results, use Beam with Python 3.</p><h2 id=overview [...]
+how to implement Beam concepts in your pipelines.</p><nav class=language-switcher><strong>Adapt
for:</strong><ul><li data-type=language-java class=active>Java SDK</li><li
data-type=language-py>Python SDK</li></ul></nav><p class=language-py>The
Python SDK supports Python 3.6, 3.7, and 3.8. Beam 2.24.0 was the last Python SDK release
to support Python 2 and 3.5.</p><h2 id=overview>1. Overview</h2><p>To
use Beam, you need to first create a driver program using the classes in one
 of the Beam SDKs. Your driver program <em>defines</em> your pipeline, including
all of
 the inputs, transforms, and outputs; it also sets execution options for your
 pipeline (typically passed in using command-line options). These include the
diff --git a/website/generated-content/documentation/sdks/python-dependencies/index.html b/website/generated-content/documentation/sdks/python-dependencies/index.html
index f9d1bb5..2d041da 100644
--- a/website/generated-content/documentation/sdks/python-dependencies/index.html
+++ b/website/generated-content/documentation/sdks/python-dependencies/index.html
@@ -6,8 +6,7 @@ import additional dependencies. Version collisions can result in unexpected
 behavior in the service. If you are using any of these packages in your code, be
 aware that some libraries are not forward-compatible and you may need to pin to
 the listed versions that will be in scope during execution.</p><p>Dependencies
for your Beam SDK version are listed in <code>setup.py</code> in the Beam repository.
To view them, perform the following steps:</p><ol><li><p>Open <code>setup.py</code>.</p><pre><code>https://raw.githubusercontent.com/apache/beam/v&lt;VERSION_NUMBER&gt;/sdks/python/setup.py
-</code></pre><p>Replace <code>&lt;VERSION_NUMBER></code>
with the major.minor.patch version of the SDK. For example, <a href=ttps://raw.githubusercontent.com/apache/beam/v2.25.0/sdks/python/setup.py
target=_blank><a href=https://raw.githubusercontent.com/apache/beam/v2.25.0/sdks/python/setup.py>https://raw.githubusercontent.com/apache/beam/v2.25.0/sdks/python/setup.py</a></a>
will provide the dependencies for the 2.25.0 release.</p></li><li><p>Review
the core dependency list under <code> [...]
-</code></pre><p>Python 2:</p><pre><code>$ pip install
virtualenv &amp;&amp; virtualenv env &amp;&amp; source env/bin/activate
+</code></pre><p>Replace <code>&lt;VERSION_NUMBER></code>
with the major.minor.patch version of the SDK. For example, <a href=ttps://raw.githubusercontent.com/apache/beam/v2.25.0/sdks/python/setup.py
target=_blank><a href=https://raw.githubusercontent.com/apache/beam/v2.25.0/sdks/python/setup.py>https://raw.githubusercontent.com/apache/beam/v2.25.0/sdks/python/setup.py</a></a>
will provide the dependencies for the 2.25.0 release.</p></li><li><p>Review
the core dependency list under <code> [...]
 </code></pre></li><li><p><a href=/get-started/quickstart-py/#download-and-install>Install
the Beam Python SDK</a>.</p></li><li><p>Retrieve the list of
dependencies.</p><pre><code>$ pip install pipdeptree &amp;&amp;
pipdeptree -p apache-beam
 </code></pre></li></ol></div></div><footer class=footer><div
class=footer__contained><div class=footer__cols><div class=footer__cols__col><div
class=footer__cols__col__logo><img src=/images/beam_logo_circle.svg class=footer__logo
alt="Beam logo"></div><div class=footer__cols__col__logo><img src=/images/apache_logo_circle.svg
class=footer__logo alt="Apache logo"></div></div><div class="footer__cols__col
footer__cols__col--md"><div class=footer__cols__col__title>Start</div><div
class=foote [...]
 <a href=http://www.apache.org>The Apache Software Foundation</a>
diff --git a/website/generated-content/sitemap.xml b/website/generated-content/sitemap.xml
index bc68318..a92a0bc 100644
--- a/website/generated-content/sitemap.xml
+++ b/website/generated-content/sitemap.xml
@@ -1 +1 @@
-<?xml version="1.0" encoding="utf-8" standalone="yes"?><urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
xmlns:xhtml="http://www.w3.org/1999/xhtml"><url><loc>/blog/beam-2.25.0/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/categories/blog/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/blog/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/categories/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/blog/b
[...]
\ No newline at end of file
+<?xml version="1.0" encoding="utf-8" standalone="yes"?><urlset xmlns="http://www.sitemaps.org/schemas/sitemap/0.9"
xmlns:xhtml="http://www.w3.org/1999/xhtml"><url><loc>/blog/beam-2.25.0/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/categories/blog/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/blog/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/categories/</loc><lastmod>2020-10-29T14:08:19-07:00</lastmod></url><url><loc>/blog/b
[...]
\ No newline at end of file


Mime
View raw message