beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Karr, David" <david.k...@wamu.net>
Subject RE: build failure?
Date Fri, 23 Jul 2004 23:17:14 GMT
The global classpath is evil.  I would hope our build doesn't depend on
the global classpath.

> -----Original Message-----
> From: Richard Feit [mailto:richard.feit@bea.com] 
> 
> I've run into this.  You need to do the build in a shell that 
> doesn't have 
> xbean.jar (the one with repackaged XMLBeans classes that comes with 
> WebLogic) on its CLASSPATH.
> Rich
> 
> At 01:04 PM 7/23/2004, Steven Tocco wrote:
> >I'm not seeing this problem
> >
> >Just did an update on trunk.
> >
> >ant clean
> >ant deploy
> >
> >Looks good to me.
> >
> >Steve
> >
> >-----Original Message-----
> >From: Zachary Smith
> >Sent: Friday, July 23, 2004 12:52 PM
> >To: beehive-dev@incubator.apache.org
> >Subject: build failure?
> >
> >I get the following when trying to build from BEEHIVE_HOME
> >
> >cd $BEEHIVE_HOME
> >ant clean deploy
> >
> >(I see this on windows and linux)
> >
> >----------------------------
> >compile.schemas:
> >
> >ant.build.xmlbean:
> >      [echo] xbean.inputs: 
> >D:/beehive/trunk/netui/src/compiler/schema/struts-conf
> >ig/*.xsd*
> >      [echo] xbean.output: 
> >D:/beehive/trunk/netui/build/lib/beehive-netui-compile
> >r.jar
> >      [echo] uptodate: ${xbean.uptodate}
> >
> >xbean_schema_compiler:
> >[xmlbeanbuild] schema/struts-config/struts-config_1_1.xsd:0: error: 
> >Document D:\ 
> >beehive\trunk\netui\src\compiler\schema\struts-config\struts-
> config_1_1
> >.
> >xsd is n
> >ot a schema file
> >[xmlbeanbuild] schema/struts-config/config.xsdconfig:0: 
> error: Document
> >D:\beehi
> >ve\trunk\netui\src\compiler\schema\struts-config\config.xsdco
> nfig is not
> >an xsd
> >config file
> >[buildmodules] Time to build schema type system: 3.676 seconds
> >[buildmodules] BUILD FAILED
> >
> >BUILD FAILED
> >D:\beehive\trunk\netui\ant\xmlBean.xml:38: null
> 
> 

Mime
View raw message