beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ken Tam" <ken...@bea.com>
Subject Annotation attribute naming conventions
Date Fri, 06 Aug 2004 21:38:34 GMT
Looking over some of our annotation type definitions, I propose we agree
on the convention to avoid Hungarian-style notation in attribute names.
For example, if an attribute's type is Class, then its name should _not_
include the word "class".  Currently
org.apache.beehive.controls.api.bean.ControlInterface has an attribute:

public Class<? extends ControlChecker> checkerClass() default
DefaultControlChecker.class;

which should instead be:

public Class<? extends ControlChecker> checker() default
DefaultControlChecker.class;

Given that the set of possible types permitted for attributes is small,
this seems more readable.

(let's NOT get into the argument of whether we should use any
Hungarian-style at all in Java :)


Mime
View raw message