beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chad Schoettger (JIRA)" <...@beehive.apache.org>
Subject [jira] Resolved: (BEEHIVE-828) @VersionRequired not supported on @ControlInterface
Date Fri, 07 Oct 2005 15:50:51 GMT
     [ http://issues.apache.org/jira/browse/BEEHIVE-828?page=all ]
     
Chad Schoettger resolved BEEHIVE-828:
-------------------------------------

    Resolution: Won't Fix
     Assign To: James Song  (was: Eddie O'Neil)

This issue appears to have stemmed from several doc issues, which have been resolved. See
BEEHIVE-197 which addresses the control's programming guide.  The java doc for the VersionRequired
annotation states it may only be applied to a interface which has been annotated by a ControlExtension
annotation.

I am resolving this issue with a "wont't fix" resolution.  

> @VersionRequired not supported on @ControlInterface
> ---------------------------------------------------
>
>          Key: BEEHIVE-828
>          URL: http://issues.apache.org/jira/browse/BEEHIVE-828
>      Project: Beehive
>         Type: Bug
>   Components: Controls
>     Versions: v1m1
>     Reporter: James Song
>     Assignee: James Song

>
> This is a follow-up of JIRA230, and JIRA-118 is related to this.
> Currently, @VersionRequired on ControlInterface causes a compile error. But, according
to http://incubator.apache.org/beehive/controls/controlsProgramming.html#Defining+an+Extended+Interface+for+a+Control+Type
, an entended control interface could be declared with @ControlInterface.
> Not supporting @VersionRequired on ControlInterface mean version control is incomplete.

-- 
This message is automatically generated by JIRA.
-
If you think it was sent incorrectly contact one of the administrators:
   http://issues.apache.org/jira/secure/Administrators.jspa
-
For more information on JIRA, see:
   http://www.atlassian.com/software/jira


Mime
View raw message