beehive-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carlin Rogers" <carlin.rog...@gmail.com>
Subject Re: [jira] problem with netui-data:repeater tag (new to beehive)
Date Wed, 24 Oct 2007 22:52:07 GMT
Hi Garlapati,

The best place for questions like this would be the Beehive - User
mailing list rather than the Dev list.

The example you provided looks correct and I ran a simple test using
your mark up. Seems to work fine. I'm curious, what version of NetUI
are you using and from what platform or IDE?

Kind regards,
Carlin


On 10/24/07, rkrgarlapati <rkrgarlapati@yahoo.com> wrote:
>
> Hi,
>
> I am new to Beehive, I am facing a typical problem,
>
>      <netui-data:repeater dataSource="pageInput.customers">
>          <netui-data:repeaterItem>
>              <li><netui:span value="${container.item.lastName},
> ${container.item.firstName}"/></li>
>          </netui-data:repeaterItem>
>      </netui-data:repeater>
>
> My problem is: in dataSource attribute i am unable to use pageInput or
> actionForm or any thing else, it's not allowing me to put anything before
> customer object.
> If i do change like : <netui-data:repeater dataSource="customers"> it's
> working fine. Requesting to clarify this typical behavior. I mean where
> would be doing wrong.
> Another problem : the tag netui:span value="${container.item.lastName}" is
> not displaying me the value of lastName, instead it was displaying me
> ${container.item.lastName} string directly on my Screen. it is very strange
> behaviour.
>
> Requesting to clarify these two questions please. as i am new to beehive, i
> am unable to trace where i am going wrong. Unfortunately i dont have access
> to this site from my office.
>
> Regards,
> garlapati
>
>
> --
> View this message in context: http://www.nabble.com/problem-with-netui-data%3Arepeater-tag-%28new-to-beehive%29-tf4686264.html#a13392536
> Sent from the Beehive - Dev mailing list archive at Nabble.com.
>
>

Mime
View raw message