bloodhound-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ben <bugrepor...@vescent.com>
Subject BH & uwsgi
Date Sun, 01 Sep 2013 16:57:02 GMT
I'm having problems with bloodhound and uwsgi. It works fine most of the 
time (and seems fast), but occasionally, it locks up such that I have I 
have to restart my uwsgi server (webserver retruns 504 gateway timeout). 
I'm running trac 0.12 on uwsgi at the same time (different uwsgi config) 
and it is unaffected. Anyone successfully running BH with uwgi?

Here's my setup: Debian Wheezy, nginx 1.2.1, uwsgi 1.2.3 and bloodhound 
0.7.

Nothing interesting in the logs.

BH logs in debug right before lock-up:

2013-09-01 12:33:28,699 Trac[env] DEBUG: Log type 'file' for product '@'
2013-09-01 12:33:28,700 Trac[env] WARNING: Inheriting parent logger for 
product '@'
2013-09-01 12:33:28,701 Trac[env] INFO: -------------------------------- 
product @ environment startup [Trac 1.0.1] --------------------------------
2013-09-01 12:33:28,708 Trac[env] DEBUG: Log type 'file' for product 'USB'
2013-09-01 12:33:28,708 Trac[env] WARNING: Inheriting parent logger for 
product 'USB'
2013-09-01 12:33:28,710 Trac[env] INFO: -------------------------------- 
product USB environment startup [Trac 1.0.1] 
--------------------------------
2013-09-01 12:33:28,717 Trac[env] DEBUG: Log type 'file' for product 'USB_2'
2013-09-01 12:33:28,717 Trac[env] WARNING: Inheriting parent logger for 
product 'USB_2'
2013-09-01 12:33:28,718 Trac[env] INFO: -------------------------------- 
product USB_2 environment startup [Trac 1.0.1] 
--------------------------------
2013-09-01 12:33:28,725 Trac[env] DEBUG: Log type 'file' for product 'Test'
2013-09-01 12:33:28,725 Trac[env] WARNING: Inheriting parent logger for 
product 'Test'
2013-09-01 12:33:28,726 Trac[env] INFO: -------------------------------- 
product Test environment startup [Trac 1.0.1] 
--------------------------------
2013-09-01 12:33:28,790 Trac[main] DEBUG: Dispatching 
<ProductRequestWithSession "GET '/admin/accounts/users'">
2013-09-01 12:33:28,799 Trac[session] DEBUG: Retrieving session for ID 
u'admin'
2013-09-01 12:33:28,807 Trac[main] DEBUG: Negotiated locale: None -> en_US
2013-09-01 12:33:29,073 Trac[svn_fs] DEBUG: Subversion bindings imported
2013-09-01 12:33:29,096 Trac[api] INFO: Synchronized 'Main' repository 
in 0.30 seconds
2013-09-01 12:33:29,099 Trac[api] DEBUG: action controllers for ticket 
workflow: ['ConfigurableTicketWorkflow']
2013-09-01 12:33:29,117 Trac[guard] DEBUG: 
AccountGuard.user_locked(admin) = None (disabled by configuration)

Likewise for uwsgi logs:

Sun Sep  1 12:32:54 2013 - ...The work of process 8786 is done. Seeya!
Sun Sep  1 12:32:55 2013 - Respawned uWSGI worker 1 (new pid: 8837)
Sun Sep  1 12:33:03 2013 - WSGI app 0 (mountpoint='/bh') ready in 0 
seconds on interpreter 0x11f1c20 pid: 8837 (default app)
[pid: 8837|app: 0|req: 1/125] 184.96.84.74 () {50 vars in 1434 bytes} 
[Sun Sep  1 12:33:03 2013] GET 
/bh/products/Serial%20IR/query?component=component1&order=priority => 
generated 36751 bytes in 2564 msecs (HTTP/1.1 200) 4 headers in 153 
bytes (0 switches on core 0)
[pid: 8837|app: 0|req: 2/126] 184.96.84.74 () {50 vars in 1481 bytes} 
[Sun Sep  1 12:33:08 2013] GET 
/bh/products/Serial%20IR/query?component=component1&order=owner => 
generated 36724 bytes in 517 msecs (HTTP/1.1 200) 4 headers in 153 bytes 
(0 switches on core 0)
[pid: 8837|app: 0|req: 3/127] 184.96.84.74 () {50 vars in 1373 bytes} 
[Sun Sep  1 12:33:22 2013] GET /bh/admin => generated 43767 bytes in 
2134 msecs (HTTP/1.1 200) 4 headers in 153 bytes (0 switches on core 0)
Sun Sep  1 12:33:24 2013 - ...The work of process 8837 is done. Seeya!
Sun Sep  1 12:33:25 2013 - Respawned uWSGI worker 1 (new pid: 8843)
Sun Sep  1 12:33:26 2013 - WSGI app 0 (mountpoint='/bh') ready in 0 
seconds on interpreter 0x11f1c20 pid: 8843 (default app)


Thanks!

Ben

Mime
View raw message