buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shane Witbeck" <sh...@digitalsanctum.com>
Subject Re: error on rake install
Date Thu, 28 Feb 2008 19:31:04 GMT
That was it. I was running with 0.9.2 and upgraded to 1.0.1 which
fixed the error.

Thanks

On 2/28/08, Victor Hugo Borja <vic.borja@gmail.com> wrote:
> Shane,
>
>  I added the install-dependencies task so that users wanting to build from
>  sources can use buildr itself to compile included classes. To this end,
>  buildr needs its required gems to be installed, however I guess
>  'rubygems/dependency_installer' is available only on recent versions of
>  rubygems (I have version 1.0.1).
>
>  On Thu, Feb 28, 2008 at 12:49 PM, Shane Witbeck <shane@digitalsanctum.com>
>  wrote:
>
>
>  > I'm getting the following at the end of a 'rake install' with the
>  > latest trunk source:
>  >
>  >  Successfully built RubyGem
>  >  Name: buildr
>  >  Version: 1.3.0
>  >  File: buildr-1.3.0.gem
>  >  Successfully built RubyGem
>  >  Name: buildr
>  >  Version: 1.3.0
>  >  File: buildr-1.3.0-java.gem
>  > Installing gem: rake (~> 0.8)
>  > rake aborted!
>  > no such file to load -- rubygems/dependency_installer
>  > C:/projects/buildr/rakefile:72
>  > (See full trace by running task with --trace)
>  >
>  >
>  > I can still install the gem that's produced.
>  >
>  > --
>  > -Shane
>  >
>
>
>
>
> --
>  vic
>
>  Quaerendo invenietis.
>


-- 
-Shane

Mime
View raw message