buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Hugo Borja" <vic.bo...@gmail.com>
Subject Re: error on rake install
Date Thu, 28 Feb 2008 19:10:16 GMT
Shane,

I added the install-dependencies task so that users wanting to build from
sources can use buildr itself to compile included classes. To this end,
buildr needs its required gems to be installed, however I guess
'rubygems/dependency_installer' is available only on recent versions of
rubygems (I have version 1.0.1).

On Thu, Feb 28, 2008 at 12:49 PM, Shane Witbeck <shane@digitalsanctum.com>
wrote:

> I'm getting the following at the end of a 'rake install' with the
> latest trunk source:
>
>  Successfully built RubyGem
>  Name: buildr
>  Version: 1.3.0
>  File: buildr-1.3.0.gem
>  Successfully built RubyGem
>  Name: buildr
>  Version: 1.3.0
>  File: buildr-1.3.0-java.gem
> Installing gem: rake (~> 0.8)
> rake aborted!
> no such file to load -- rubygems/dependency_installer
> C:/projects/buildr/rakefile:72
> (See full trace by running task with --trace)
>
>
> I can still install the gem that's produced.
>
> --
> -Shane
>



-- 
vic

Quaerendo invenietis.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message