buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Tal Rotbart" <redbe...@gmail.com>
Subject Re: JDK 1.6 developer preview on Mac OS X
Date Mon, 25 Feb 2008 03:29:06 GMT
Weird. I just noticed Buildr pretends to run my tests but doesn't,
this is under jruby.
Maybe I'm doing something wrong, and if this belongs in buildr-user
(even though 1.3 isn't yet released) let me know.

Steps I took:

1. Downloaded jruby
2. Added it to my PATH
3. Verified 'which rake', 'which gem' point to the jruby.
4. Installed buildr into jruby gems from trunk by using 'rake install'.
5. Running buildr using 'jruby /usr/bin/buildr clean package' (My
/usr/bin/buildr's content is listed below.)

May it have something to do with including Junit 4.4 and/or Jmock 2.4?
In any case, some sort of error would be great.
I'd be happy to look into it if you told me where to start.

Cheers,
Tal


/usr/bin/buildr:
---
#!/System/Library/Frameworks/Ruby.framework/Versions/1.8/usr/bin/ruby
#
# This file was generated by RubyGems.
#
# The application 'buildr' is installed as part of a gem, and
# this file is here to facilitate running it.
#

require 'rubygems'

version = ">= 0"

if ARGV.first =~ /^_(.*)_$/ and Gem::Version.correct? $1 then
  version = $1
  ARGV.shift
end


gem 'buildr', version
load 'buildr'
---

On Mon, Feb 25, 2008 at 1:32 PM, Tal Rotbart <redbeard@gmail.com> wrote:
> Just tried it, works incredibly well!
>  I see you also made the gem not dependent on rjb when installed from
>  jruby's rubygem. Nice touch.
>
>  You guys rock!
>
>  Cheers,
>  Tal
>
>
>
>  On Mon, Feb 25, 2008 at 12:59 PM, Assaf Arkin <arkin@intalio.com> wrote:
>  > On Feb 24, 2008, at 5:58 PM, Tal Rotbart wrote:
>  >
>  >  > Hi Assaf,
>  >  >
>  >  > Thanks. But that obviously doesn't solve RBJs problem.
>  >  > Any remaining issues running from jruby on trunk? That might be the
>  >  > only workaround.
>  >
>  >  None that we know of, JRuby support should be complete and pretty fast
>  >  on Java 6.
>  >
>  >  Assaf
>  >
>  >
>  >
>  >  >
>  >  >
>  >  > Cheers,
>  >  > Tal
>  >  >
>  >  >
>  >  > On Mon, Feb 25, 2008 at 12:13 PM, Assaf Arkin <arkin@intalio.com>
>  >  > wrote:
>  >  >>
>  >  >> On Feb 24, 2008, at 4:43 PM, Tal Rotbart wrote:
>  >  >>
>  >  >>> Hi all,
>  >  >>>
>  >  >>> Does any of you have experience with updating Buildr / Antwrap /
RJB
>  >  >>> to work with JDK 1.6 Developer Preview on Mac OS X?
>  >  >>>
>  >  >>> It seems that even after uninstalling all version of rjb and Antwrap
>  >  >>> and reinstalling with JAVA_HOME pointing to the JDK 1.6's home
>  >  >>> folder
>  >  >>> at:
>  >  >>> /System/Library/Frameworks/JavaVM.framework/Versions/1.6.0/Home
>  >  >>>
>  >  >>> When using buildr (with JAVA_HOME set correctly as well) the Ant
>  >  >>> tasks
>  >  >>> launched by Antwrap still seem to use the 1.5 javac, classpath and
>  >  >>> tools.jar.
>  >  >>>
>  >  >>> Any clues would be appreciated greatly.
>  >  >>
>  >  >> Remove line 19 in lib/java.java.rb, that should do it.
>  >  >>
>  >  >> Assaf
>  >  >>
>  >  >>>
>  >  >>>
>  >  >>> Cheers,
>  >  >>> Tal
>  >  >>
>  >  >>
>  >
>  >
>

Mime
View raw message