buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Contal" <antoine.con...@gmail.com>
Subject Re: [buildr] rake install
Date Wed, 27 Feb 2008 22:08:54 GMT
Alex,

Thank you for the tip.  After patching and updating, the 'rake
install' command works on my system now (svn revision 631747).

I still have two issues.

1. 'rake spec' fails with
/usr/lib/ruby/site_ruby/1.8/rake.rb:2028:in `const_missing':
uninitialized constant Rake::Task::TaskArguments (NameError)

2. My project objects do not have an 'ant' method anymore, as they
used to in version 1.2.10.  Has the project API changed?

antoine

On Wed, Feb 27, 2008 at 10:52 PM, Alex Boisvert <boisvert@intalio.com> wrote:
> You can avoid this error by locally patching your Rakefile,
>
>  -    spec.extra_rdoc_files = ['README', 'CHANGELOG', 'LICENSE', 'NOTICE',
>  'DISCLAIMER', 'reports/specs.html']
>  +    spec.extra_rdoc_files = ['README', 'CHANGELOG', 'LICENSE', 'NOTICE',
>  'DISCLAIMER']
>
>  Looks like the build assumes you've run the specs tests before doing an
>  install.
>
>  alex
>
>
>  On 2/27/08, Antoine Contal <antoine.contal@gmail.com> wrote:
>  >
>
>
> > Hi!
>  >
>  > I tried to build the buildr trunk as explained in
>  > contributing.textile, but I have not been very successful at it.  I
>  > think I need some help.
>  >
>  > $ svn up
>  > At revision 631733.
>  > $ rake install
>  > (in /home/l/code/buildr/buildr-trunk)
>  > Compiling Java libraries ... rake aborted!
>  > undefined method `javac=' for
>  > #<Buildr::Java::CompileTask::Options:0xb75e745c>
>  > /home/l/code/buildr/buildr-trunk/buildfile:7
>  > (See full trace by running task with --trace)
>  > OK
>  > rake aborted!
>  > Don't know how to build task 'reports/specs.html'
>  >
>  > (See full trace by running task with --trace)
>  > $
>  >
>  > My environment is as follows.
>  > $ ruby --version
>  > ruby 1.8.6 (2007-03-13 patchlevel 0) [i586-linux-gnu]
>  > $ buildr --version
>  > Buildr, version 1.2.10
>  > $ java -version
>  > java version "1.5.0_11"
>  > Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_11-b03)
>  > Java HotSpot(TM) Client VM (build 1.5.0_11-b03, mixed mode)
>  > $ prince --version
>  > Prince 6.0 rev 5
>  > Copyright 2002-2008 YesLogic Pty. Ltd.
>  > Personal License
>  >
>  > There is something I find strange in the rake file.
>  > On line 64, I see that the 'install' task depends on the 'package' task.
>  > On line 55, I see that the 'package' task depends on the 'compile' task.
>  > And on line 52, I see that the 'compile' task needs a buildr command.
>  >
>  > How do you install buildr if you do not already have buildr?
>  >
>  > Cheers.
>  >
>  >
>  > antoine

Mime
View raw message