buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Contal" <antoine.con...@gmail.com>
Subject Re: [buildr] rake install
Date Thu, 28 Feb 2008 22:03:40 GMT
Assaf,

On Wed, Feb 27, 2008 at 11:23 PM, Assaf Arkin <arkin@intalio.com> wrote:
>  The spec.html problem was me playing with stuff and accidentally
>  committing it.  Gone now.

OK. No harm done.

>  > 1. 'rake spec' fails with
>  > /usr/lib/ruby/site_ruby/1.8/rake.rb:2028:in `const_missing':
>  > uninitialized constant Rake::Task::TaskArguments (NameError)
>
>  Make sure you have Rake 0.8.1.  Unfortunately, 1.2.x can only run on
>  7.x, and 1.3 requires 8.x because of the task argument addition.

It does look like I have Rake 0.8.1 already installed on my system.

$ rake --version && rake spec
rake, version 0.8.1
(in /home/lacton/code/buildr/buildr-trunk)
/usr/lib/ruby/site_ruby/1.8/rake.rb:2028:in `const_missing':
uninitialized constant Rake::Task::TaskArguments (NameError)
        from /home/lacton/code/buildr/buildr-trunk/lib/core/common.rb:97:in
`invoke'
        from /home/lacton/code/buildr/buildr-trunk/lib/java/rjb.rb:98:in `load'
        from /home/lacton/code/buildr/buildr-trunk/lib/java/rjb.rb:98:in `each'
        from /home/lacton/code/buildr/buildr-trunk/lib/java/rjb.rb:98:in `load'
        from /home/lacton/code/buildr/buildr-trunk/spec/sandbox.rb:21
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`gem_original_require'
        from /usr/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:27:in
`require'
        from ./spec/spec_helpers.rb:30
        from ./spec/java_test_frameworks_spec.rb:17:in `require'
        from ./spec/java_test_frameworks_spec.rb:17
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib/spec/runner/example_group_runner.rb:14:in
`load'
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib/spec/runner/example_group_runner.rb:14:in
`load_files'
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib/spec/runner/example_group_runner.rb:13:in
`each'
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib/spec/runner/example_group_runner.rb:13:in
`load_files'
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib/spec/runner/options.rb:85:in
`run_examples'
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib/spec/runner/command_line.rb:19:in
`run'
        from /usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/bin/spec:4
rake aborted!
Command ruby -I"/usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/lib"
"/usr/lib/ruby/gems/1.8/gems/rspec-1.1.3/bin/spec"
"spec/packaging_spec.rb" "spec/project_spec.rb" "spec/common_spec.rb"
"spec/compile_spec.rb" "spec/transport_spec.rb"
"spec/artifact_spec.rb" "spec/build_spec.rb" "spec/test_spec.rb"
"spec/checks_spec.rb" "spec/archive_spec.rb"
"spec/java_test_frameworks_spec.rb" "spec/java_packaging_spec.rb"
"spec/java_compilers_spec.rb" "spec/scala_compilers_spec.rb"
"spec/groovy_compilers_spec.rb" --options spec/spec.opts --format
failing_examples:failing failed

Does it mean that somehow the wrong version of Rake gets invoked
during the spec run?

>  > 2. My project objects do not have an 'ant' method anymore, as they
>  > used to in version 1.2.10.  Has the project API changed?
>  >
>  Adding this back.

OK, thanks.

antoine

Mime
View raw message