buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Contal" <antoine.con...@gmail.com>
Subject Re: [buildr] rake install
Date Fri, 29 Feb 2008 07:23:37 GMT
Assaf,

On Fri, Feb 29, 2008 at 12:45 AM, Assaf Arkin <arkin@intalio.com> wrote:
>  Try:
>
>  ruby -e "require 'rake';puts RAKEVERSION"

$ rake --version
rake, version 0.8.1
$ ruby -e "require 'rake';puts RAKEVERSION"
0.7.3

>  I'm guessing you have two copies of Rake, newer one in Gems and older
>  one in site_ruby, and Buildr is picking the older one for some
>  reason.

You are right. The rake in /usr/lib/ruby/site_ruby/1.8/ is the one
that comes with my Mandriva 2008 Linux distribution.  The rake in
/usr/lib/ruby/gems/1.8/gems/rake-0.8.1 is the one that was installed
by the 'gem install' command.

>  We need to figure out how to fix this.

$ ruby -e "require 'rubygems';require 'buildr';puts RAKEVERSION"
0.8.1

Somehow, the buildr module is able to find the right rake installation.

antoine

Mime
View raw message