buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Shane Witbeck" <sh...@digitalsanctum.com>
Subject a strong suggestion
Date Sat, 31 May 2008 13:45:09 GMT
Being a buildr user for almost a year now and having a vested interest
in seeing Buildr continue to be successful, I'd like to make a strong
suggestion.

It seems that now, just after the 1.3.1 release, there's another
dependency issue around Antwrap, hoe, and rubyforge. So yet again the
standard way of installing is broken and will most likely discourage a
lot of newcomers to Buildr knowing they have to constantly work around
the dependency issues. I realize this is a caveat of a remote
dependency system but I really think we need to do a better job of
either documenting these issues (on the main Buildr site) or start
assembling installs to insulate ourselves from the dependency-related
woes. In my opinion, this should be the top priority above all other
planned features.

Has anyone else considered making the installs easier and less prone
to these issues?

-- 
-Shane

Mime
View raw message