buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Re: problems installing from head
Date Mon, 19 May 2008 22:31:00 GMT
On Sat, May 17, 2008 at 4:50 AM, Shane Witbeck <shane@digitalsanctum.com>
wrote:

> I'm attempting to install from the latest source in head and running
> into an issue with the install insisting that I'm missing gem
> dependencies that I already have installed. See below for an example:
>
> jackal:buildr shane$ sudo rake install
> (in /Users/shane/projects/thirdparty/buildr)
> Missing Gems rjb (~> 1.1, != 1.1.3), rake (~> 0.8), builder (~> 2.1),
> net-ssh (~> 2.0), net-sftp (~> 2.0), rubyzip (~> 0.9), highline (~>
> 1.4), Antwrap (~> 0.7), rspec (~> 1.1), xml-simple (~> 1.0),
> archive-tar-minitar (~> 0.5), rubyforge (~> 0.4), please run rake
> setup first!
> rake aborted!
> undefined method `win_platform?' for Gem:Module
>
> (See full trace by running task with --trace)
> jackal:buildr shane$ gem list builder
>
> *** LOCAL GEMS ***
>
> builder (2.1.2)
>    Builders for MarkUp.
> jackal:buildr shane$
>
>
> --------
>
> Running 'sudu rake setup' results in the same issue. This is MRI on OS
> X. Any pointers?


Old version of RubyGems?  rake setup/install are only tested with the latest
and greatest, and there are some API differences between 0.9.x and 1.1.x,
which might explain why it's not seeing already installed Gems.

Assaf


>
>
>
> --
> -Shane
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message