buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Tommy Knowlton <to...@ke4kug.net>
Subject Re: Transitive dependencies, version matching and OSGi support
Date Mon, 05 May 2008 03:01:02 GMT
Would Buildr do better to accept the same version range syntax that  
maven2 already accepts? In fact, if parsing POM's, it would seem that  
such syntax must already be supported, although I confess I haven't  
tried this.

Cheers,
Tommy

On May 2, 2008, at 3:41 PM, Assaf Arkin wrote:

> Version matching makes it possible to point at the most recent  
> version that
> satisfies a particular version requirement, so >=1.2 to get 1.2.0 or  
> later,
> or ~>1.2.3 to get any version between 1.2.3 and 1.3 (excluding).


Mime
View raw message