buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Hugo Borja" <vic.bo...@gmail.com>
Subject Re: spec LoadError with jruby 1.1.4
Date Mon, 01 Sep 2008 19:30:26 GMT
I've fixed the Java.load issue for JRuby 1.1.4 in
http://tinyurl.com/5rbfme, however I don't like much the fact that
jars need to be loaded on the
system class-loader.
For the javadoc tool adding tools.jar seems like the only way to make it
find the standard doclet.
And for some reason, java_test_frameworks_spec.rb was failing unless all
jars were loaded on system CL.

So we still load the buildr classpath in the system CL. :)

Side note: should we upgrade buildr to require jruby 1.1.4, it seems like it
loads/runs faster than 1.1.3 ?

On Sun, Aug 31, 2008 at 12:51 PM, Assaf Arkin <arkin@intalio.com> wrote:

> It's a problem somewhere in lib/java/jruby.rb, the load method fails
> when trying to mess with the classloader.
>
> Assaf
>
> On Sun, Aug 31, 2008 at 10:32 AM, Victor Hugo Borja <vic.borja@gmail.com>
> wrote:
> > It seems trying to run an spec using jruby 1.1.4(java 6) fails when
> loading
> > sandbox.rb, also tried 'load' instead of require with same results...
> >
> > vic@zabbai-lael:~/hk/buildr$ /opt/jruby-1.1.4/bin/jruby -S
> > /opt/jruby-1.1.4/bin/spec spec/application_spec.rb
> > /opt/jruby-1.1.4/lib/ruby/site_ruby/1.8/rubygems/custom_require.rb:34:in
> > `require': IO error -- /home/vic/hk/buildr/spec/sandbox (LoadError)
> >        from /home/vic/hk/buildr/./spec/application_spec.rb:17
> >        from /home/vic/hk/buildr/./spec/application_spec.rb:14:in `load'
> >        from
> >
> /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/lib/spec/runner/example_group_runner.rb:14:in
> > `load_files'
> >        from
> >
> /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/lib/spec/runner/example_group_runner.rb:13:in
> > `each'
> >        from
> >
> /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/lib/spec/runner/example_group_runner.rb:13:in
> > `load_files'
> >        from
> >
> /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/lib/spec/runner/options.rb:98:in
> > `run_examples'
> >        from
> >
> /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/lib/spec/runner/command_line.rb:19:in
> > `run'
> >        from
> /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/bin/spec:4
> >        from
> > /opt/jruby-1.1.4/lib/ruby/gems/1.8/gems/rspec-1.1.4/bin/spec:19:in `load'
> >        from /opt/jruby-1.1.4/bin/spec:19
> >
> > JRuby 1.1.3 doesn't have this issue.
> > Anyone else having this problem, or any idea on how to get it to work?
> >
> > --
> > vic
> >
> > Quaerendo invenietis.
> >
>



-- 
vic

Quaerendo invenietis.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message