buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Victor Hugo Borja" <vic.bo...@gmail.com>
Subject Re: Replacing VERSION/REQUIRES with version/dependencies and using YAML files to pick versions of specific libraries
Date Wed, 17 Sep 2008 07:44:21 GMT
On Wed, Sep 17, 2008 at 1:57 AM, Victor Hugo Borja <vic.borja@gmail.com>wrote:

> [...] I'd also like something more qualified (and more rubyish..) like
>    Buildr::Ant::version: 1
>

What do you think about this:

To let the user specify JUnit::dependencies without having to override the
method:

A build.yml having something like..

  Buildr::JUnit::dependencies:
    - junit:junit:jar:4.4
    - jserious:jserious:jar:1.0
    - jserious:jserious-tools:jar:1.0

And on Buildr::JUnit @buildr/java/tests.rb:185

      def dependencies
        @dependencies ||= Buildr.settings.build[name+'::dependencies'] ||
            ["junit:junit:jar:#{version}"]+ JMock.dependencies
      end

-- 
vic

Quaerendo invenietis.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message