buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Eung-ju Park" <eun...@gmail.com>
Subject Re: Current Rakefile is broken
Date Sat, 13 Sep 2008 16:58:37 GMT
I guess two changes makes buildr can't work with rake 0.8.2.

1.
http://github.com/jimweirich/rake/commit/68303da1aeda78533c044f2a01a99a619fdb1932Prerequisites
are no longer FileLists

2.
http://github.com/jimweirich/rake/commit/41a334b4e6bd3175202675ad289668f457ef73a9Applied
optparse patch
Buildr::Application extends Rake::Application. In rake 0.8.2, command-line
argument parsing has changed. So there is some mismatch.


On Sun, Sep 14, 2008 at 12:02 AM, Eung-ju Park <eungju@gmail.com> wrote:

> rake 0.8.2 causes the problem. 'rake install' works after I downgrade rake
> to 0.8.1.
>
>
> On Sat, Sep 13, 2008 at 11:17 PM, Eung-ju Park <eungju@gmail.com> wrote:
>
>>
>>
>> On Sat, Sep 13, 2008 at 10:12 PM, lacton <lacton@users.sourceforge.net>wrote:
>>
>>> On Sat, Sep 13, 2008 at 2:01 PM, Eung-ju Park <eungju@gmail.com> wrote:
>>> > I tried to build buildr but it raise error like below.
>>> >
>>> > $ rake
>>> > (in /Users/eungju/src/buildr)
>>> > rake aborted!
>>> > undefined method `include' for []:Array
>>> > /Users/eungju/src/buildr/rakefile:46
>>> > (See full trace by running task with --trace)
>>>
>>> That's interesting.  When I run 'rake' with no task name, I get "Don't
>>> know how to build task 'default'".
>>>
>>> What version of rake are you using? (i.e., 'rake --version')
>>> What SVN revision are you building from? (i.e., 'svn info | grep
>>> Revision')
>>
>>
>> here it is
>> $ ruby --version
>> ruby 1.8.6 (2008-03-03 patchlevel 114) [universal-darwin9.0]
>> $ rake --version
>> rake, version 0.8.2
>> $ svn info | grep Revision
>> Revision: 694906
>>
>>
>>
>>>
>>>
>>> > I don't know about rake but I tried something. I guess attached patch
>>> will
>>> > fix it.
>>>
>>> Which patch are you referring to?
>>
>>
>> Mailing list doesn't deliver attachment files. Here is the patch
>>
>> Index: Rakefile
>> ===================================================================
>> --- Rakefile    (revision 694906)
>> +++ Rakefile    (working copy)
>> @@ -43,11 +43,12 @@
>>  ENV['incubating'] = 'true'
>>  ENV['staging'] = "people.apache.org:~/public_html/#{spec.name
>> }/#{spec.version}"
>>
>> -task('apache.license').prerequisites.include(spec.files).
>> +task 'apache:license' do |task|
>> +  task.prerequisites.include(spec.files).
>>    exclude('.class', '.png', '.jar', '.tif', '.textile', '.icns',
>>             'README', 'LICENSE', 'CHANGELOG', 'DISCLAIMER', 'NOTICE',
>> 'etc/KEYS', 'etc/git-svn-authors')
>> +end
>>
>> -
>>  task 'spec:check' do
>>    print 'Checking that we have JRuby, Scala and Groovy available ... '
>>    fail 'Full testing requires JRuby!' unless which('jruby')
>>
>>
>>
>>>
>>>
>>> Lacton
>>>
>>
>>
>> --
>> * LukeSkywalker: Is the dark side stronger?
>> * MasterYoda: No...no...no. Quicker, easier, more seductive.
>>
>
>
>
> --
> * LukeSkywalker: Is the dark side stronger?
> * MasterYoda: No...no...no. Quicker, easier, more seductive.
>



-- 
* LukeSkywalker: Is the dark side stronger?
* MasterYoda: No...no...no. Quicker, easier, more seductive.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message