buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Spiewak <djspie...@gmail.com>
Subject Re: Buildr 1.4.0RC2 is out
Date Tue, 11 May 2010 22:33:39 GMT
Alex, could you try running the specs, see if everything works?  It's  
good to hear that Buildr installs though, it's farther than I got.  :-)

Daniel

On May 11, 2010, at 5:32 PM, "Antoine Toulme" <antoine@lunar- 
ocean.com> wrote:

> So we're good to go, or do I have to buy a Windows 7 machine to test  
> this
> out ?
>
> On Sat, May 8, 2010 at 07:58, Alex Boisvert  
> <alex.boisvert@gmail.com> wrote:
>
>> For what it's worth, 1.4.0 RC3 installed cleanly on my Windows 7  
>> machine:
>>
>> C:\Users\Owner\Downloads>gem install buildr-1.4.0-x86-mswin32.gem
>> **************************************************
>>
>> Thank you for installing rspec-1.2.9
>>
>> Please be sure to read History.rdoc and Upgrade.rdoc
>> for useful information about this release.
>>
>> **************************************************
>> To get started run buildr --help
>> Successfully installed json_pure-1.4.0
>> Successfully installed rubyforge-2.0.3
>> Successfully installed rspec-1.2.9
>> Successfully installed buildr-1.4.0-x86-mswin32
>> 4 gems installed
>> Installing ri documentation for json_pure-1.4.0...
>> Installing ri documentation for rubyforge-2.0.3...
>> Installing ri documentation for rspec-1.2.9...
>> Installing ri documentation for buildr-1.4.0-x86-mswin32...
>> Installing RDoc documentation for json_pure-1.4.0...
>> Installing RDoc documentation for rubyforge-2.0.3...
>> Installing RDoc documentation for rspec-1.2.9...
>> Could not find main page README.rdoc
>> Could not find main page README.rdoc
>> Could not find main page README.rdoc
>> Could not find main page README.rdoc
>> Installing RDoc documentation for buildr-1.4.0-x86-mswin32...
>>
>> C:\Users\Owner\Downloads>
>>
>> and I was able to 'sucessfully' build the Apache Ode trunk... up to  
>> a point
>> where it failed with a compile error.
>>
>> alex
>>
>>
>> On Thu, May 6, 2010 at 9:56 AM, Alex Boisvert  
>> <alex.boisvert@gmail.com
>>> wrote:
>>
>>> Haven't gotten to it yet;  my Windows machine suffered a power- 
>>> supply
>>> blowout yesterday when I turned it on :(
>>>
>>> alex
>>>
>>>
>>> On Wed, May 5, 2010 at 11:39 AM, Daniel Spiewak <djspiewak@gmail.com
>>> wrote:
>>>
>>>> My testing didn't get very far, since gem was unable to build the
>>>> dependencies when I ran `rake setup` under MRI.  I'm guessing  
>>>> either our
>>>> gemspec is wrong, or Gem itself has a bug w.r.t. Windows 7  
>>>> x86_64.  I
>> had
>>>> other problems with JRuby (not Buildr-related) and wasn't able to  
>>>> do any
>>>> meaningful testing in that area.
>>>>
>>>> Hopefully Alex had more luck.  :-)
>>>>
>>>> Daniel
>>>>
>>>> On Wed, May 5, 2010 at 1:17 PM, Antoine Toulme <antoine@lunar-ocean.com
>>>>> wrote:
>>>>
>>>>> Did you get anything from the testing ? Or should I consider  
>>>>> getting a
>>>> VM
>>>>> (please, no, please!)
>>>>>
>>>>> On Tue, May 4, 2010 at 15:04, Daniel Spiewak <djspiewak@gmail.com>
>>>> wrote:
>>>>>
>>>>>> I have Windows 7, so I'll try to do some quick testing tonight.
>>>>>> Hopefully the fix is something reasonably straightforward; it  
>>>>>> would
>> be
>>>>>> disappointing if windows 7 broke Buildr in more fundamental ways.
>>>>>>
>>>>>> Daniel
>>>>>>
>>>>>> On May 4, 2010, at 5:01 PM, Antoine Toulme <antoine@lunar-ocean.com
>>>
>>>>>> wrote:
>>>>>>
>>>>>>> I don't have a windows 7 machine handy for testing so I'm kinda
>>>> stuck.
>>>>>>>
>>>>>>> On Tue, May 4, 2010 at 14:56, Alex Boisvert
>>>>>>> <alex.boisvert@gmail.com> wrote:
>>>>>>>
>>>>>>>> On Tue, May 4, 2010 at 2:28 PM, Antoine Toulme <
>>>>> antoine@lunar-ocean.com
>>>>>>>>> wrote:
>>>>>>>>
>>>>>>>>> We have spec failures on Windows 7, and it looks like
we might
>>>>>>>>> need to
>>>>>>>>> change packaging for that new OS.
>>>>>>>>>
>>>>>>>>
>>>>>>>> It would be good to know if the release actually works on
>> Windows.
>>>>>>>>
>>>>>>>> Are the spec failures false negatives, or blocking issues?
>>>>>>>>
>>>>>>>>
>>>>>>>> I would be ok with releasing now but we will need a maintenance
>>>>>>>> release
>>>>>>>>> with
>>>>>>>>> complete windows 7 support and JRuby 1.5 quickly.
>>>>>>>>>
>>>>>>>>
>>>>>>>> Same here, assuming there are no real blockers on Windows.
>>>>>>>>
>>>>>>>> I wouldn't want people running "gem update" on Windows and
>> finding
>>>>>>>> their
>>>>>>>> Buildr install broken.
>>>>>>>>
>>>>>>>> alex
>>>>>>>>
>>>>>>>>
>>>>>>
>>>>>
>>>>
>>>
>>>
>>

Mime
View raw message