buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@realityforge.org>
Subject Re: Ant 1.8.1 upgrade requires Antwrap changes
Date Fri, 02 Jul 2010 02:25:05 GMT
One thing I would like to see is an update to the dependency
declaration of jruby-openssl either to an open ended version range or
to the latest version. i.e. to either '>= 0.5.2' or '= 0.7'.   I would
add a jira issue but I seem to log on atm.

On Fri, Jul 2, 2010 at 2:43 AM, Antoine Toulme <antoine@lunar-ocean.com> wrote:
> Cool!
>
> Here's the changelog so far:
>
> 1.4.1 (pending)
> * Added:  BUILDR-420 Support external compiler
> * Added:  BUILDR-425 Specify dev dependencies in .gemspec
> * Change: BUILDR-459 Update gemspec to accept json_pure ~> 1.4.3
> * Fixed:  BUILDR-455 cc_spec.rb l 160 depends on time and thus fails
> intermittently
> * Fixed:  BUILDR-461 Packages with different ids collide
> * Fixed:  BUILDR-439 "The command line is too long" when running TestNG
> tests
>
> I'll cut a RC tonight/tomorrow morning.
>
> On Thu, Jul 1, 2010 at 09:13, Alex Boisvert <alex.boisvert@gmail.com> wrote:
>
>> On Wed, Jun 30, 2010 at 11:53 AM, Antoine Toulme <antoine@lunar-ocean.com>wrote:
>>
>>> I was wrong, it's a dependency of junit.
>>>
>>> So we will need to upgrade junit to match with 1.8.1.
>>>
>>> For the time being, I reverted to 1.8.0.
>>>
>>> I have a few failures when running rake spec as the external compiler spec
>>> changes the order of the compilers. I will fix that today.
>>>
>>> I am thinking of making a release this Friday. I'll bring up a changelog
>>> this Friday and we can discuss if we feel like releasing ?
>>>
>>
>> I think it's a good idea to release soon.  BUILDR-459 (json_pure ~> 1.4.3)
>> seems to be the driver.
>>
>> alex
>>
>>
>



-- 
Cheers,

Peter Donald

Mime
View raw message