buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Daniel Spiewak <djspie...@gmail.com>
Subject Re: [VOTE] Buildr 1.4.1 release
Date Fri, 02 Jul 2010 14:32:43 GMT
Doesn't it seem just a little quick to be pushing out 1.4.1?  I don't object
too strenuously, but it just seems a bit weird.

Daniel

On Fri, Jul 2, 2010 at 1:14 AM, Antoine Toulme <antoine@lunar-ocean.com>wrote:

> We're voting on the source distributions available here:
> http://people.apache.org/~toulmean/buildr/1.4.1/dist/<http://people.apache.org/%7Etoulmean/buildr/1.4.1/dist/>
>
> Specifically:
> http://people.apache.org/~toulmean/buildr/1.4.1/dist/buildr-1.4.1.tgz<http://people.apache.org/%7Etoulmean/buildr/1.4.1/dist/buildr-1.4.1.tgz>
> http://people.apache.org/~toulmean/buildr/1.4.1/dist/buildr-1.4.1.zip<http://people.apache.org/%7Etoulmean/buildr/1.4.1/dist/buildr-1.4.1.zip>
>
> The documentation generated for this release is available here:
> http://people.apache.org/~toulmean/buildr/1.4.1/site/<http://people.apache.org/%7Etoulmean/buildr/1.4.1/site/>
> http://people.apache.org/~toulmean/buildr/1.4.1/site/buildr.pdf<http://people.apache.org/%7Etoulmean/buildr/1.4.1/site/buildr.pdf>
>
> The official specification against which this release was tested:
> http://people.apache.org/~toulmean/buildr/1.4.1/site/specs.html<http://people.apache.org/%7Etoulmean/buildr/1.4.1/site/specs.html>
>
> Test coverage report:
> http://people.apache.org/~toulmean/buildr/1.4.1/site/coverage/index.html<http://people.apache.org/%7Etoulmean/buildr/1.4.1/site/coverage/index.html>
>
>
> The following changes were made since 1.4.0:
>
>  * Added:  BUILDR-420 Support external compiler
>  * Added:  BUILDR-425 Specify dev dependencies in .gemspec
>  * Change: BUILDR-459 Update gemspec to accept json_pure ~> 1.4.3
>  * Fixed:  BUILDR-455 cc_spec.rb l 160 depends on time and thus fails
> intermittently
>  * Fixed:  BUILDR-461 Packages with different ids collide
>  * Fixed:  BUILDR-439 "The command line is too long" when running TestNG
> tests
>  * Fixed:  BUILDR-463 Setting a system property in the buildfile causes a
> NoClassDefFoundError
>
> This vote is opened for 72h!
>
> Thanks,
>
> Antoine
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message