buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Alex Boisvert <alex.boisv...@gmail.com>
Subject Re: Build failed in Hudson: Buildr-ci-build #175
Date Wed, 03 Nov 2010 16:13:54 GMT
Antoine, when you get a chance could you gem install rspec 2.0.1 in your
hudson account?

thanks,
alex


On Wed, Nov 3, 2010 at 9:01 AM, Apache Hudson Server <
hudson@hudson.apache.org> wrote:

> See <https://hudson.apache.org/hudson/job/Buildr-ci-build/175/changes>
>
> Changes:
>
> [boisvert] More rspec 2.0.0 tweaks; use rspec 2.0.1
>
> [boisvert] More RSpec 2.0.0 changes
>
> [boisvert] More RSpec-related tweaks; specs now run on Ruby 1.9
>
> ------------------------------------------
> Started by an SCM change
> Building remotely on ubuntu2
> Updating http://svn.apache.org/repos/asf/buildr/trunk
> U         Rakefile
> U         spec/packaging/artifact_namespace_spec.rb
> U         spec/core/shell_spec.rb
> U         spec/spec_helpers.rb
> U         buildr.gemspec
> U         lib/buildr.rb
> At revision 1030508
> [Buildr-ci-build] $ /bin/bash -xe /tmp/hudson6782943619533580513.sh
> + export JAVA_HOME=/home/hudson/tools/java/latest1.6-64
> + JAVA_HOME=/home/hudson/tools/java/latest1.6-64
> + export SCALA_HOME=/home/toulmean/scala-2.8.0.final
> + SCALA_HOME=/home/toulmean/scala-2.8.0.final
> + export JRUBY_HOME=/home/toulmean/jruby-1.5.2
> + JRUBY_HOME=/home/toulmean/jruby-1.5.2
> + export GEM_HOME=/home/toulmean/buildr-gems
> + GEM_HOME=/home/toulmean/buildr-gems
> + export 'JAVA_OPTS=-Xmx256m -XX:MaxPermSize=256m'
> + JAVA_OPTS='-Xmx256m -XX:MaxPermSize=256m'
> + export
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/hudson/.rvm/bin:/home/toulmean/buildr-gems/bin
> +
> PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games:/home/hudson/.rvm/bin:/home/toulmean/buildr-gems/bin
> + ruby1.8 -S /home/toulmean/buildr-gems/bin/rake ci
> ruby1.8 <https://hudson.apache.org/hudson/job/Buildr-ci-build/ws/_buildr>
> --buildfile buildr.buildfile compile
> (in <https://hudson.apache.org/hudson/job/Buildr-ci-build/ws/)>
> Compiling Java libraries ...
> /usr/local/lib/site_ruby/1.8/rubygems.rb:777:in `report_activate_error':
> RubyGem version error: rspec(1.2.9 not = 2.0.1) (Gem::LoadError)
>        from /usr/local/lib/site_ruby/1.8/rubygems.rb:211:in `activate'
>        from /usr/local/lib/site_ruby/1.8/rubygems.rb:1056:in `gem'
>        from <
> https://hudson.apache.org/hudson/job/Buildr-ci-build/ws/_buildr>:30
>        from <
> https://hudson.apache.org/hudson/job/Buildr-ci-build/ws/_buildr>:29:in
> `each'
>        from <
> https://hudson.apache.org/hudson/job/Buildr-ci-build/ws/_buildr>:29
> rake aborted!
> Command failed with status (1): [ruby1.8
> /home/hudson/hudson-slave/workspac...]
>
> (See full trace by running task with --trace)
> Recording test results
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message