buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@realityforge.org>
Subject Re: alias :project :define
Date Wed, 17 Nov 2010 08:14:30 GMT
> I was initially thinking about do_first and do_last but though the "do" was
> redundant with Ruby's do ... end notation.   Do you think that's better?

Not greatly. Maybe firstly and lastly?

task(:foo).firstly do
  # block will be executed before 'enhance' blocks
end

task(:foo).lastly do
  # block will be executed after 'enhance' blocks
end

That way it does not double up the "do" word and doesn't look like an
enumeration.

-- 
Cheers,

Peter Donald

Mime
View raw message