buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Peter Donald <pe...@realityforge.org>
Subject Re: can't run specs (scala-reflect 2.9.2)
Date Sat, 16 Aug 2014 03:50:07 GMT
Hi,

Sorry for not replying earlier - been caught up in other things and
only just had a chance to get back to this.

On Wed, Aug 13, 2014 at 12:49 AM, Jean-Philippe Caruana
<jp@target2sell.com> wrote:
> Le 07/08/2014 15:43, Jean-Philippe Caruana a écrit :
>> Why did you do to reproduce the problem ?
>
> Not Why, but How...

I am not actually sure but I certainly can not reproduce this back on
OSX. I suspect it has something to do with the version of rubygems or
the platform.  (I did manage to re-prdoduce this under a Linux variant
...).

I believe it has something to do with the way versions are represented
in different platforms. See the failure that has been appearing in
TravisCI for a while

https://travis-ci.org/apache/buildr/jobs/32118453#L2559

This seems to indicate that the behaviour of the Gem::Version class
has changed over time and the buildr code needs to be updated to
follow it. In buildr we have code that compared the version of scala
and only included those deps if the version is high enough

https://github.com/apache/buildr/blob/master/lib/buildr/scala/compiler.rb#L147

However as you have a scala version of 2.9.2, it should NOT be
included but unfortunately it is. So my guess is that as soon as we
fix the version problem this will go away too.

-- 
Cheers,

Peter Donald

Mime
View raw message