buildr-dev mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Toulme <anto...@toulme.name>
Subject Re: [DISCUSS] Scala support
Date Sun, 14 Aug 2016 07:33:15 GMT
Circling back:
> On May 1, 2016, at 7:54 AM, Alex Boisvert <alex.boisvert@gmail.com> wrote:
> 
> On Sat, Apr 30, 2016 at 12:04 PM, Antoine Toulme <antoine@lunar-ocean.com>
> wrote:
> 
>> Does it make sense to move to 2.11.8, or should we move to the latest 2.12
>> milestone? I would like to shoot for the latter.
>> 
> 
> Nobody is using 2.12 yet; so I think we should move to 2.11.x.
OK, I see it now. Makes sense.
> 
> 
>> We are still using JDK7 for now but need to think of moving to JDK8 soon.
>> 
>> With version 1.5, we can make the jump.
>> 
> 
> Version 1.5 should support 2.10, 2.11 and 2.12.   (And support for 2.12
> will require JDK 8, but we should still support 2.10 and 2.11 with JDK 7).
> 
> Agree with can drop support for JDK6.
> 
> Do we have motivation to target only JDK 8?   If so, what is it?
This was in the same alignment as supporting 2.12, which I read only will work with JDK8.

Since we’re going to standardize on 2.11, we’re good for some time.

I have done some work to move to 2.11 but it’s been slow going, mostly because I’m not
quite familiar with the Scala ecosystem. It’s coming though.
Mime
View raw message