buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Re: does builder work with jruby?
Date Mon, 19 Nov 2007 17:47:03 GMT
Stephen,

Buildr doesn't yet work with JRuby, only CRuby for now.

Assaf

On 11/18/07, Stephen Bannasch <stephen.bannasch@deanbrook.org> wrote:
> Does builder work with jruby?
>
> When I tried to install it one of the dependencies, rjb, required
> compilation of native extensions.
>
> $ gem install buildr -y
> Select which gem to install for your platform (java)
>   1. Antwrap 0.6.0 (ruby)
>   2. Antwrap 0.6.0 (java)
>   3. Skip this gem
>   4. Cancel installation
> >  2
> Select which gem to install for your platform (java)
>   1. rjb 1.0.11 (ruby)
>   2. rjb 1.0.11 (mswin32)
>   3. Skip this gem
>   4. Cancel installation
> >  1
> Building native extensions.  This could take a while...
> extconf.rb:6:in `require': no such file to load -- mkmf (LoadError)
> ERROR:  While executing gem ... (Gem::Installer::ExtensionBuildError)
>      ERROR: Failed to build gem native extension.
>


-- 
CTO, Intalio
http://www.intalio.com

Mime
View raw message