buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ingo Schmidt" <>
Subject [No Subject]
Date Wed, 09 Apr 2008 14:34:14 GMT

I have now tried for the first time to use buildr's upload feature, soI added those lines
for testing purposes to my build script:
repositories.release_to[:username] = "buildr"
repositories.release_to[:password] = "buildr"
repositories.release_to[:url] = "sftp://myhost/var/www/repo"

It does connect to "myhost" just fine, but it always prompts for apassword, even though the
password above is definitely correct, becauseif I then manually type it, it works.
So how do I make this one work automatically? I am running buildr on Windows XP Pro.

Then I updated my working copy to HEAD. My old revision was 619691. Wow, so many changes :)

Unfortunately, some of  these seem to break my build script:
- I can no longer use "Buildr.environment" to access the environmentvariable passed via "-e"
switch. I know buildr now uses profiles, butwhy did you throw out "Buildr.environment" completely?
Just curious,the fix is easy (ENV['BUILDR_ENV']).
- the following no longer works:
  runtimeResources = zip("target/").include("src/main/java/**").exclude("*.java",
"*.xsd", "*.bat")
This will now include everything under "src/main/java", regardless of the excludes I specified.
- also this line causes an error:
  package(:jar).merge(runtimeResources, :path=> "/")
It says:
different prefix: "//de/mypackage" and "C:/"
It happens in "relative_path_from".
The problem can be solved by changing the line like so:

I also had a lot of trouble compiling buildr under Windows. I finallymanaged to install the
missing gems, trying to avoid "failed to buildgem native extension". But when I installed
the buildr.gem I just builtform sources, I got just this error message again. It turns out
that itdid try to install rjb-1.1.3 as a dependency. rjb-1.1.3, however, doesnot have precompiled
mswin32 gems.
I had installed "rjb-1.1.2-x86-mswin32-60.gem". If I install myself-built buildr.gem with
"--ignore-dependencies" it will run justfine.
So does buildr depend on the latest rjb or just one that is higher thanx? If the latter is
the case, should it then not just accept thatversion?

Other than that I am still happy with buildr, even though all these ruby dependency stuff
gave me quite some headaches...

Cheers, Ingo =;->

  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message