buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Arkin" <ar...@intalio.com>
Subject Re:
Date Thu, 10 Apr 2008 01:08:20 GMT
On Wed, Apr 9, 2008 at 7:34 AM, Ingo Schmidt <antispam@der-ingo.de> wrote:

> Hi!
>
> I have now tried for the first time to use buildr's upload feature, soI
> added those lines for testing purposes to my build script:
> repositories.release_to[:username] = "buildr"
> repositories.release_to[:password] = "buildr"
> repositories.release_to[:url] = "sftp://myhost/var/www/repo"
>
> It does connect to "myhost" just fine, but it always prompts for
> apassword, even though the password above is definitely correct, becauseif I
> then manually type it, it works.
> So how do I make this one work automatically? I am running buildr on
> Windows XP Pro.


The change in SVN should accept the password (untested, running on blind
faith)


>
>
> Then I updated my working copy to HEAD. My old revision was 619691. Wow,
> so many changes :)
>
> Unfortunately, some of  these seem to break my build script:
> - I can no longer use "Buildr.environment" to access the
> environmentvariable passed via "-e" switch. I know buildr now uses profiles,
> butwhy did you throw out "Buildr.environment" completely? Just curious,the
> fix is easy (ENV['BUILDR_ENV']).


That got dropped when I reorganized some files around, added it back.


>
> - the following no longer works:
>  runtimeResources =
> zip("target/resources.zip").include("src/main/java/**").exclude("*.java",
> "*.xsd", "*.bat")


This shouldn't work, but '**/*.java' would as would '**/*.{java,xsd,bat}'.

>
> This will now include everything under "src/main/java", regardless of the
> excludes I specified.
> - also this line causes an error:
>  package(:jar).merge(runtimeResources, :path=> "/")
> It says:
> different prefix: "//de/mypackage" and "C:/"
> It happens in "relative_path_from".
> The problem can be solved by changing the line like so:
>    package(:jar).path("/").merge(runtimeResources)


Fixed.


>
> I also had a lot of trouble compiling buildr under Windows. I
> finallymanaged to install the missing gems, trying to avoid "failed to
> buildgem native extension". But when I installed the buildr.gem I just
> builtform sources, I got just this error message again. It turns out that
> itdid try to install rjb-1.1.3 as a dependency. rjb-1.1.3, however, doesnot
> have precompiled mswin32 gems.
> I had installed "rjb-1.1.2-x86-mswin32-60.gem". If I install myself-built
> buildr.gem with "--ignore-dependencies" it will run justfine.
> So does buildr depend on the latest rjb or just one that is higher thanx?
> If the latter is the case, should it then not just accept thatversion?


Basically we don't need the latest version of RJB, and I can confirm 1.1.3
doesn't work on Windows.  I'm trying to find a way to have it skip 1.1.3.


Other than that I am still happy with buildr, even though all these ruby
> dependency stuff gave me quite some headaches...


Sorry about that.

I just proposed on buildr-dev that we do a feature freeze on 1.3 and just
work on stability, outstanding bugs and documentations, towards a release.

Assaf


>
>
>
> Cheers, Ingo =;->
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message