buildr-users mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Victor Hugo Borja <vic.bo...@gmail.com>
Subject Re: buildr on jruby and windows, sort of success.
Date Sun, 06 Apr 2008 09:49:18 GMT
Tomas Carlsson wrote:
> Thanks for a great build system!
Welcome and thank you for using Buildr and giving us feedback!

>  * "jruby -S rake setup" does not work because "sudo" is called in the gem
> install command. So I manually installed the deps listed in Rakefile (jruby
> -S gem install ...).
Fixed rake setup, tested with a fresh JRuby 1.1 ;)

>  * "jruby -S rake spec" fails on
>         ./spec/application_spec.rb:279:in `describe': can't convert Symbol
> into String (TypeError)
>     but it seems you dont _have_ to run the tests.
Fixed application_spec.rb on trunk

> * I had to edit the ./buildfile to "require 'buildr/nailgun'" instead of
> "require 'buildr/java/nailgun'"
Yes, nailgun.rb was recently moved to the addon directory.

> * The install of the buildr gem fails because it calls "sudo". So I ran that
> command manually: "jruby -S gem install pkg\buildr-1.3.0-java.gem"
Should be working now.

> This worked for me. Now I just have to check that buildr trunk on jruby
> works with my projects :-)
Again, thanks for trying Buildr, we welcome any comment or issue you may 
  find, we need more users/developers running Windows ;)

Mime
View raw message